Bug 473433 - After Install F10 fails to boot
After Install F10 fails to boot
Status: CLOSED DUPLICATE of bug 429937
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 09:07 EST by Ed
Modified: 2009-02-24 22:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 20:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed 2008-11-28 09:07:02 EST
Description of problem:

Install went fine, found SCSI drive fine, video looks great!, loaded all apps from install DVD [ not live spin DVD ].  When rebooting to "firstboot" the white and blue lines chased each other 90% across the bottom, the "Fedora 10" logo went from dim to bright.

At this point I received a text screen that says: 
VolGroup00 not found
Unable to Access Resume Device ( /dev/VolGroup00/LogVol01 )
mount: error mounting /dev/root on /sysroot as ext3: no such file or directory

Then 2 blocks of SCSI defs with correct parameters :

sda sda1 sda2
3 0.0.0.0 size, etc

and a block indicating the drive was attached a generic sg2 0

This system runs and boots fine with F8, tried 2 other new, clean drives same thing.

System is an Intel MB with 3ghz Pent with HT [ old duo ? I think ] and 2 GB ram, Adaptec SCSI 320 adapter with Seagate 72 gb 15k SCSI 320 drive ST 373455LW . Video is ATI ..  


Version-Release number of selected component (if applicable):

Fedora 10

How reproducible:

100%

Steps to Reproduce:
1. Install F10 on new, clean drive from i386 install DVD
2. When booting after install boot fails with above message
3.
  
Actual results:

Boot fails

Expected results:

Boot into "firstboot"

Additional info:
Comment 1 Ed 2008-11-28 18:48:03 EST
Tried different video card, went from Radeon 9200 to good old matrox g450, video is awesome, now I see the comet heading to the sun, BUT same result, at about 90% of boot I get the text screen with error as posted above.

DVD verifies tests and was able to load successfully on a spare server we had.

Tried another older PC and won't load there either.
Comment 2 Ed 2008-12-01 08:36:02 EST
I was able to regen the initrd file after adding /etc/mkinitrd with MODULES="scsi_wait_scan"

The system boots now.  After researching this issue I see it's been around for many iterations of F10 development.

This system is a fresh install and will install and boot F8 and F9 production releases.

This is a desktop and the Adaptec SCSI/320 controller is an add-on.
Comment 3 Jeff Gustafson 2008-12-05 18:16:17 EST
This issue just bit me.  Sure enough, adding scsi_wait_scan fixed the problem. Can this be made a default?  Is there any harm in making this a default?
Comment 4 Gabriel Somlo 2008-12-22 13:59:14 EST
Same issue here: Dell PowerEdge 2650 with hardware raid-0 setup

lspci:
...
04:08.1 RAID bus controller: Dell PowerEdge Expandable RAID Controller 3/Di (rev 01)
05:06.0 SCSI storage controller: Adaptec RAID subsystem HBA (rev 01)
05:06.1 SCSI storage controller: Adaptec RAID subsystem HBA (rev 01)
...

lsmod:
aic7xxx               102308  0 
scsi_transport_spi     21760  1 aic7xxx
...
scsi_wait_scan          5120  0 
...

booting from rescue F10 image, and doing

chroot /mnt/sysimage "mkinitrd -v -f --with=scsi_wait_scan /boot/initrd-2.6.27.7-134.fc10.i686.img 2.6.27.7-134.fc10.i686"

fixed the issue.

I believe this bug is also a dupe of:
https://bugzilla.redhat.com/show_bug.cgi?id=429937
Comment 5 lexual 2009-02-24 20:08:57 EST

*** This bug has been marked as a duplicate of bug 429937 ***

Note You need to log in before you can comment on or make changes to this bug.