Bug 47345 - Long directory path goes off the page
Long directory path goes off the page
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: jadetex (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 21:06 EDT by Stephen Rasku
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 10:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug.sgml (805 bytes, text/plain)
2001-07-04 21:07 EDT, Stephen Rasku
no flags Details
bug.ps (20.92 KB, text/plain)
2001-07-04 21:09 EDT, Stephen Rasku
no flags Details
fix.ps (20.93 KB, text/plain)
2001-07-30 12:44 EDT, Tim Waugh
no flags Details
Here's the fix that I'm currently considering putting into jadetex. (288 bytes, patch)
2001-07-31 04:58 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Stephen Rasku 2001-07-04 21:06:09 EDT
Description of Problem:


How Reproducible:
100%

Steps to Reproduce:
1.  db2ps <filename>

Actual Results:

If I have a long directory path in a document it goes off the side of the
page.

Expected Results:

Long pathnames should be split or put on a separate line so that they don't
go off the edge of the page.

Additional Information:
	
Using docbook-utils-0.6-13.

Will attach SGML file and resulting postscript.
Comment 1 Stephen Rasku 2001-07-04 21:07:27 EDT
Created attachment 22708 [details]
bug.sgml
Comment 2 Stephen Rasku 2001-07-04 21:09:23 EDT
Created attachment 22709 [details]
bug.ps
Comment 3 Tim Waugh 2001-07-30 07:19:37 EDT
This problem goes away when this is commented out of 
/usr/share/sgml/docbook/utils-*/docbook-utils.dsl:

;;What quadding do you want by default; start, center, justify, or end?
(define %default-quadding%
 'justify)

David, do you think that this is the correct solution? (docbook-utils.dsl is 
actually the GNOME stylesheet..)
Comment 4 David Mason 2001-07-30 11:12:15 EDT
I don't think that solves the problem across the board does it? I always
understood this to be an odd TeX problem that Norman Walsh said was almost
impossible to correct from the DSSSL side. If we see that more cases are
corrected without the quadding we can change it though
Comment 5 Tim Waugh 2001-07-30 12:43:41 EDT
Oh, okay, I see how that comes about.

How about getting jadetex to put '\setlength\emergencystretch{2in}' at the 
beginning of its output?  That way, in case of overfull hboxes, an extra 
stretchable length gets added to the end of the lines.

To see, try this:

$ docbook2tex bug.sgml
$ echo '\setlength\emergencystretch{2in}' > fix.tex
$ cat bug.tex >> fix.tex
$ jadetex fix.tex; jadetex fix.tex; jadetex fix.tex
$ dvips -o fix.ps fix.dvi

Doing that gives me this result (attached).  I wonder if there's some reason 
that jadetex doesn't already set \emergencystretch.
Comment 6 Tim Waugh 2001-07-30 12:44:10 EDT
Created attachment 25431 [details]
fix.ps
Comment 7 Tim Waugh 2001-07-30 12:48:09 EDT
*ahem* I mean openjade of course, not jadetex.
Comment 8 David Mason 2001-07-30 12:50:02 EDT
thats exactly the issue I believe. 
I will ask Sebastian Rahtz the next time I see him online... I believe he is one
of the people responsible
Comment 9 Tim Waugh 2001-07-30 12:52:11 EDT
Right.  Looking further into this actually I probably _do_ mean jadetex, since 
that's where this stuff should get set.
Comment 10 Tim Waugh 2001-07-31 04:58:45 EDT
Created attachment 25551 [details]
Here's the fix that I'm currently considering putting into jadetex.
Comment 11 Tim Waugh 2001-08-03 10:08:57 EDT
I have applied this fix in jadetex-3.6-2.

Note You need to log in before you can comment on or make changes to this bug.