Bug 47346 - ppp on demand crashes Readhat 7.1 (seawolf)
ppp on demand crashes Readhat 7.1 (seawolf)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 21:39 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-04 21:39:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
ppp on demand on Readhat 7.1 (seawolf)The System hangs at startup while 
attempting to briging up ppp device.


This is a clean FULL install.

How reproducible:
Always

Steps to Reproduce:
1.edit /etc/sysconfig/network-scripts/ifcfg-ppp0 add yes to the demand line
2.Reboot system
3.Watch system not start and hang on ppp


Actual Results:  tough one here, the system as expected didnt start, so I 
had to push the big button on the front to cycle the power and watch it 
not start again and again and again.

Expected Results:  The system should have started

Additional info:

No output messages, as the system never made it far enough to generate 
any. Yet I could watch over and over the pretty little green OK prompts 
that would appear everytime before I had to hit the cycle power button.
Comment 1 Need Real Name 2001-08-20 01:28:50 EDT
Same symptoms for me. Ihave a ZyXEL Elite 2864ID and have been trying to
configure it to be used for DoD. If I change "DEMAND=yes" to "no" in
/etc/sysconfig/network-scripts/ifcfg-pppX, everything is fine, else I have A
Zombie ifup-ppp and /etc/init.d/network start does'nt work. 

Aditionaly, if i ping an address outside of my subnet, the interface is dialing
and everything works fine. Mayibe it is because pppd not dialing the line with
the 'demand'- parm?
Comment 2 gmelder 2001-09-07 14:42:54 EDT
Check out the proposed fix for bug # 37392. I think this is the same problem.
Comment 3 Need Real Name 2001-09-15 00:39:08 EDT
In reference to bug id #37392, The bug appears to be the same listed, but the 
potential resolution does not work. I have tried all manners of the potential 
configurations regarding detach updetach nodetach and with no entry at all. 
Most yeild the same results, as the system hanging on the ppp device. Others 
give error codes that resolve to unknown options.

This problem is still unresolved and even with the new kernel and all new 
patches applied, nothing has been fixed.
Comment 4 gmelder 2001-09-24 16:39:40 EDT
What follows is an amendment to the solution originally proposed in bug # 37392:

In addition to my proposed solution above, you may also need to do the
following:

Locate the line in /etc/sysconfig/network-scripts/ifup-ppp that reads as:
exec /sbin/ppp-watch "${DEVICE}" "$@"
(this is line 17 on my installation)
and insert a # symbol at the beginning of that line to comment it out.

ppp-watch attempts to provide on-demand functionality for a ppp link.
Unfortunately, in this script, it only results in a contentious redundancy with
pppd's default behavior, which is to wait in the background anyway, like the
good little daemon that it is.

NEVER give up. LMK what results you all get.

- gabriel
Comment 5 Thomas Woerner 2004-08-13 05:28:45 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.