Bug 473460 - firstboot aborts when trying to set a dictionary-based password
firstboot aborts when trying to set a dictionary-based password
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 11:18 EST by Eduardo Habkost
Modified: 2009-09-03 09:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 09:10:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2008-11-28 11:18:58 EST
Package versions:
firstboot-1.102-1.fc10.x86_64
cracklib-2.8.13-1.x86_64
cracklib-python-2.8.13-1.x86_64

When trying to set an user password based on a dictionary word, instead of simply showing a warning, firstboot aborted with this exception:

============
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/firstboot/interface.py", line 102, in _nextClicked
    self.advance()
  File "/usr/lib64/python2.5/site-packages/firstboot/interface.py", line 147, in advance
    result = module.apply(self, self.testing)
  File "/usr/share/firstboot/modules/create_user.py", line 89, in apply
    elif not userGroupCheck.isPasswordOk(password, self.passwordEntry):
  File "/usr/share/system-config-users/userGroupCheck.py", line 145, in isPasswordOk
    clerror = cracklib.FascistCheck (str)
ValueError: it is based on a dictionary word


Since there is a problem, firstboot will exit.

Please file a bug against 'firstboot' in the Red Hat
bug tracking system at http://www.redhat.com/bugzilla.
A copy of the debug output has been saved to /tmp/firstboot-ITfQoz
Be sure to attach that file to the bug report.
=========
Comment 1 Chris Lumens 2008-12-02 10:18:14 EST
Looks like cracklib has changed its error reporting a bit and system-config-users needs to be made aware of it.  The following patch should take care of it.

diff -ru system-config-users-1.2.81/src/userGroupCheck.py system-config-users-1.2.81.NEW/src/userGroupCheck.py
--- system-config-users-1.2.81/src/userGroupCheck.py    2008-10-30 12:39:20.000000000 -0400
+++ system-config-users-1.2.81.NEW/src/userGroupCheck.py        2008-12-02 10:16:27.000000000 -0500
@@ -142,7 +142,11 @@
     if not have_cracklib:
         return True
 
-    clerror = cracklib.FascistCheck (str)
+    try:
+        clerror = cracklib.FascistCheck (str)
+    except ValueError, e:
+        clerror = e.msg
+
     if clerror:
         # translate error message
         clerror = _(clerror)
Comment 2 Nils Philippsen 2008-12-03 06:32:45 EST
Thanks for the patch, applied in the upstream repo.
Comment 3 Bug Zapper 2009-06-09 05:58:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Nils Philippsen 2009-09-03 09:10:55 EDT
fixed since 1.2.83

Note You need to log in before you can comment on or make changes to this bug.