Bug 47347 - Starting X sends pppd a SIGHUP, closing ppp connection.
Summary: Starting X sends pppd a SIGHUP, closing ppp connection.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-05 02:34 UTC by Ben Logan
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:28:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Logan 2001-07-05 02:34:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586; Nav)

Description of problem:
Everytime I connect to my ISP (using the ifup script), and then start X
(either with 'startx' or by invoking xinit), pppd exits, and the log
messages simply say that it received a SIGHUP and is exiting.

I'm using the standard setup as rp3-config creates it: i.e., 
/etc/wvdial.conf, /etc/ppp/peers/ppp*, and
/etc/sysconfig/network-scripts/ifcfg-ppp* contain the configuration info.

How reproducible:
Always

Steps to Reproduce:
1. Run "ifup ppp0" to connect to ISP.
2. Run "startx" to start X.


Actual Results:  pppd dies with signal SIGHUP

Additional info:

ppp-2.4.0-2
XFree86-4.0.3-5
wvdial-1.41-12

My connection to my ISP is via dialup modem.
I've also looked in the X log messages, but found nothing relevant.

Comment 1 Juan Carlos Castro y Castro 2001-07-05 03:16:47 UTC
Similar thing happens to me with a few differences:

- I go into X first and then use the Red Hat dialer (which calls wvdial);
- Connection dies randomly, and /var/log/messages has the same thing as
blogan's, which is like that:

Jul  5 00:05:58 localhost pppd[2024]: Hangup (SIGHUP)
Jul  5 00:05:58 localhost pppd[2024]: Modem hangup
Jul  5 00:05:58 localhost pppd[2024]: Connection terminated.
Jul  5 00:05:58 localhost pppd[2024]: Connect time 4.0 minutes.
Jul  5 00:05:58 localhost pppd[2024]: Sent 30852 bytes, received 597326 bytes.

- And lastly, there are times when the connection stays active for a
surprisingly long time. I haven't the faintest idea who sends this @#$%& SIGHUP
to pppd. Any way of figuring that out?

Comment 2 Ben Logan 2001-08-27 13:56:54 UTC
I just upgraded my kernel from the stock 2.4.2-2 to 2.4.5-ac12 and that fixed
the problem of X killing pppd.  I guess it was a bug in the kernel?

Comment 3 Thomas Woerner 2004-08-13 09:28:42 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.