Bug 473494 - dmraid: malloc(): memory corruption
dmraid: malloc(): memory corruption
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 15:22 EST by Christophe Furmaniak
Modified: 2009-12-18 06:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:00:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshw log (24.30 KB, text/plain)
2008-11-28 15:22 EST, Christophe Furmaniak
no flags Details
dmesg (43.08 KB, text/plain)
2008-11-28 15:24 EST, Christophe Furmaniak
no flags Details
output result of dmraid -rD (533 bytes, application/x-bzip2)
2008-12-13 08:30 EST, Christophe Furmaniak
no flags Details
dd results (502 bytes, application/x-bzip2)
2009-01-11 13:45 EST, Christophe Furmaniak
no flags Details
Fix segfault when attempting to generate name for jmicron controllers (1.01 KB, patch)
2009-03-20 09:42 EDT, Giuseppe Iuculano
no flags Details | Diff

  None (edit)
Description Christophe Furmaniak 2008-11-28 15:22:46 EST
Created attachment 325037 [details]
lshw log

Description of problem:
dmraid crashes with a  malloc(): memory corruption message

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc15-2.fc10.x86_64
dmraid-libs-1.0.0.rc15-2.fc10.x86_64


How reproducible: always happens on my system:

Gigabyte P35C-DS3R
64 bits

with 4 disk on the intel ICH9 controller
the first 2 (including the one on which is install fedora) are not in a raid array
the last 2 are on a raid0 array

no disks on the jmicron controller


Steps to Reproduce:
1.dmraid -vay
  
Actual results:

[root@loozbox01 ~]# dmraid -vay
/dev/sdd: "jmicron" and "isw" formats discovered (using isw)!
*** glibc detected *** dmraid: malloc(): memory corruption: 0x000000000089cd00 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3022a7b1cf]
/lib64/libc.so.6(__libc_malloc+0x98)[0x3022a7ca08]
dmraid[0x40ffde]
dmraid[0x40a94c]
dmraid(free_raid_dev+0x25)[0x40aa75]
dmraid[0x40b7ef]
dmraid(discover_raid_devices+0xf3)[0x40d0d3]
dmraid(lib_perform+0x17f)[0x40d2ef]
dmraid(main+0x6e)[0x403f5e]
/lib64/libc.so.6(__libc_start_main+0xe6)[0x3022a1e546]
dmraid[0x403e29]
======= Memory map: ========
00400000-00431000 r-xp 00000000 08:02 752230                             /sbin/dmraid
00630000-00634000 rw-p 00030000 08:02 752230                             /sbin/dmraid
0089b000-008bc000 rw-p 0089b000 00:00 0                                  [heap]
3021200000-3021220000 r-xp 00000000 08:02 253555                         /lib64/ld-2.9.so
302141f000-3021420000 r--p 0001f000 08:02 253555                         /lib64/ld-2.9.so
3021420000-3021421000 rw-p 00020000 08:02 253555                         /lib64/ld-2.9.so
3022200000-3022239000 r-xp 00000000 08:02 253575                         /lib64/libsepol.so.1
3022239000-3022439000 ---p 00039000 08:02 253575                         /lib64/libsepol.so.1
3022439000-302243a000 rw-p 00039000 08:02 253575                         /lib64/libsepol.so.1
3022600000-3022615000 r-xp 00000000 08:02 253831                         /lib64/libdevmapper.so.1.02
3022615000-3022815000 ---p 00015000 08:02 253831                         /lib64/libdevmapper.so.1.02
3022815000-3022817000 rw-p 00015000 08:02 253831                         /lib64/libdevmapper.so.1.02
3022a00000-3022b68000 r-xp 00000000 08:02 253557                         /lib64/libc-2.9.so
3022b68000-3022d68000 ---p 00168000 08:02 253557                         /lib64/libc-2.9.so
3022d68000-3022d6c000 r--p 00168000 08:02 253557                         /lib64/libc-2.9.so
3022d6c000-3022d6d000 rw-p 0016c000 08:02 253557                         /lib64/libc-2.9.so
3022d6d000-3022d72000 rw-p 3022d6d000 00:00 0 
3023200000-3023202000 r-xp 00000000 08:02 253791                         /lib64/libdl-2.9.so
3023202000-3023402000 ---p 00002000 08:02 253791                         /lib64/libdl-2.9.so
3023402000-3023403000 r--p 00002000 08:02 253791                         /lib64/libdl-2.9.so
3023403000-3023404000 rw-p 00003000 08:02 253791                         /lib64/libdl-2.9.so
3023e00000-3023e1a000 r-xp 00000000 08:02 253793                         /lib64/libselinux.so.1
3023e1a000-3024019000 ---p 0001a000 08:02 253793                         /lib64/libselinux.so.1
3024019000-302401a000 r--p 00019000 08:02 253793                         /lib64/libselinux.so.1
302401a000-302401b000 rw-p 0001a000 08:02 253793                         /lib64/libselinux.so.1
302401b000-302401c000 rw-p 302401b000 00:00 0 
302e400000-302e416000 r-xp 00000000 08:02 253813                         /lib64/libgcc_s-4.3.2-20081105.so.1
302e416000-302e616000 ---p 00016000 08:02 253813                         /lib64/libgcc_s-4.3.2-20081105.so.1
302e616000-302e617000 rw-p 00016000 08:02 253813                         /lib64/libgcc_s-4.3.2-20081105.so.1
7fdd8c000000-7fdd8c021000 rw-p 7fdd8c000000 00:00 0 
7fdd8c021000-7fdd90000000 ---p 7fdd8c021000 00:00 0 
7fdd91ee1000-7fdd91ee4000 rw-p 7fdd91ee1000 00:00 0 
7fdd91ef7000-7fdd91efa000 rw-p 7fdd91ef7000 00:00 0 
7fff99ee5000-7fff99efa000 rw-p 7ffffffea000 00:00 0                      [stack]
7fff99fff000-7fff9a000000 r-xp 7fff99fff000 00:00 0                      [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
Abandon



Additional info:
Comment 1 Christophe Furmaniak 2008-11-28 15:24:00 EST
Created attachment 325038 [details]
dmesg
Comment 2 Christophe Furmaniak 2008-11-29 08:50:34 EST
I should have said that it worked without any pb on FC8
Comment 3 Heinz Mauelshagen 2008-12-10 14:02:36 EST
Christophe,

can you please attach "dmraid -rD" output files (*.{dat,offset,size}) if possible in a bzip2/tarball here to allow me to try reproducing this with your data, thanks ? If dmraid failes for you, dd the last 4KB off each disk of the RAID set into files $DiskName.dat (e.g. sda.dat) and put the size in sectors into files $DiskName.size into the bzip2/tarball.

There could be a HW (ie. RAM) flaw which gets triggered by optimizations in newer kernels. If possible, run memtest.
Comment 4 Christophe Furmaniak 2008-12-13 08:30:34 EST
Created attachment 326815 [details]
output result of dmraid -rD

Here are the ouput results of the dmraid -rD command.

However, dmraid -rD ended with a segfault so I don't know if the output are as complete as you wished.
Comment 5 Christophe Furmaniak 2008-12-13 08:33:28 EST
Could you please give me the command to run to retreive the last 4KB off each disk of the RAID using dd please?
Comment 6 Heinz Mauelshagen 2009-01-09 07:23:50 EST
find the size of each disk in sectors (say $sectors) and

dd if=/dev/$DiskName skip=$((sectors - 8)) bs=512 of=$DiskName.dat

for each $DiskName.

Please don't forget to add $DiskName.size with the sectors count in.
Comment 7 Christophe Furmaniak 2009-01-11 13:45:22 EST
Created attachment 328672 [details]
dd results

here are the results of the dd command on the two disks in the raid0 array
Comment 8 Luca Taglialegne 2009-02-10 03:32:32 EST
I have the identical problem, my configuration is GIGABYTE P35-DS3R, 4GB RAM Fedora 10 x86_64 and two Seagate 1TB Disk in mirror on jmicron controller.

If needs other infos ask for.
Comment 9 Giuseppe Iuculano 2009-03-03 02:34:33 EST
It sounds me as an old bug fixed in the previous release with dmraid-1.0.0.rc14-jmicron-name.patch[1]

[1]http://cvs.fedoraproject.org/viewvc/devel/dmraid/dmraid-1.0.0.rc14-jmicron-name.patch?revision=1.1&view=markup
Comment 10 Giuseppe Iuculano 2009-03-20 09:42:24 EDT
Created attachment 336048 [details]
Fix segfault when attempting to generate name for jmicron controllers

Attached patch should fix this issue.
Comment 11 Christophe Furmaniak 2009-04-23 11:56:00 EDT
Thanks Giuseppe for the hint!

It really seems related to jmicron controllers (my mother board hosts both jmicron and ICH9 controllers) because using the -f flag to specify to deal only with the ICH9/isw controller, everything seems OK

dmraid -ay -f isw
RAID set "isw_bgfiiahjia_Volume0" was activated
RAID set "isw_bgfiiahjia_Volume0p1" was activated
RAID set "isw_bgfiiahjia_Volume0p2" was activated
RAID set "isw_bgfiiahjia_Volume0p3" was activated


Ok, I could/should have tried before...if only I had read the man page more carefully.
Comment 12 Bug Zapper 2009-11-18 04:02:54 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-12-18 02:00:49 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.