Bug 473502 - Preserving partitions during install obscure or awkward; Disk Druid
Preserving partitions during install obscure or awkward; Disk Druid
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2008-11-28 17:37 EST by Stephen P. Schaefer
Modified: 2009-09-09 13:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 05:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen P. Schaefer 2008-11-28 17:37:30 EST
Description of problem:
During install, it was non-obvious how to prevent wiping the /home partition

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from Fedora 10 install media
2. Choose Install
3. At Disk Druid, choose custom partitioning
4. Disk Druid discovers existing partitions
5. ?
  
Actual results:
It appears any defined partition (esp. ext3) will get reformatted

Expected results:
*Desired* result: A "Protect Partition from changes" status

Additional info:
I would have felt safe deleting the /home partition and then defining it again later in the MBR, but yuck.  I felt frightened that anything left defined as ext3 would get mke2fs'd.  I cancelled out and did an upgrade instead of an install.  Since "install" instead of "upgrade" is recommended, the procedure for doing this highly common procedure should be highlighted in the documentation instead of obscure or missing.
Comment 1 Nicolas Troncoso Carrere 2008-11-30 10:06:20 EST
There are aditional artifacts for diskdruid:
Pre-install layout:
/dev/sda1 /boot
/dev/sda2 / (encrypted dm-crypt)
/dev/sda3 swap (encrypted dm-crypt)
/dev/sda4 /home (encrypted dm-crypt)

When instructing drisk druid to format and encrypt /dev/sda2 / it does not update the icons status that notify of formating and encription. 

It does this properly for /dev/sda1 /boot and /dev/sda3 swap.

If you delete the /dev/sda2 partition and recreate, format and encrypt it will update the status icons.
Comment 2 Joel Andres Granados 2009-09-09 05:36:47 EDT
(In reply to comment #0)
> Description of problem:
> During install, it was non-obvious how to prevent wiping the /home partition

I beg to differ.  If you don't want to format it, just don't edit it (with the condition that you did not choose to autopartition).  And, If you chose an autopartition option ("Use entire drive", "Replace existing Linux system"), it is obvious that your /home is most probably going to get formatted.

> 
> Actual results:
> It appears any defined partition (esp. ext3) will get reformatted

This is not the case.  When you select *only* custom partitioning everything starts off as we detect it.  If you choose to some default partitioning scheme and accept to review the layout after the autopartitioning is done, the devices to be formatted are chosen automatically.

In the case where the user wants full control of the installation, like your case, he/she should choose the custom layout and be very specific about what is wanted.  I don't see what is awkward or obscure about that.

With respect to the second comment.  Pls open a new bug if this is still the case with f12 alpha.
Comment 3 Stephen P. Schaefer 2009-09-09 13:05:39 EDT
During the F10 install, Disk Druid said it was going to mkfs "ext partitions".  It nowhere indicated it was going to exclude existing partitions.  If the GUI has been clarified since, good.

Note You need to log in before you can comment on or make changes to this bug.