Bug 473508 - preupgrade should ensure restorecon is run after upgrade
preupgrade should ensure restorecon is run after upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 18:35 EST by Matt Domsch
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 19:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-11-28 18:35:56 EST
Description of problem:
preupgrade does not cause restorecon to be run after upgrade.  Following an upgrade from F9 to F10, I was unable to ssh into the system because ~/.ssh was labeled incorrectly, though it was labeled correctly for F9's selinux policy.

preupgrade should somehow ensure restorecon is run after upgrade.  This may be touching /.autorelabel or doing the relabel towards the end of anaconda.

Version-Release number of selected component (if applicable):
1.0.0-1.fc9
Comment 1 Will Woods 2008-11-28 19:51:20 EST
Everything that happens to the system during the upgrade is anaconda's responsiblity; reassigning.
Comment 2 Daniel Walsh 2008-12-04 16:19:53 EST
This was caused by a bug in selinux-policy, It should not have required a relabel.

Adding a relabel would take too long.

The label is now correct in selinux-policy-3.5.13-31

Note You need to log in before you can comment on or make changes to this bug.