Bug 473511 - F10 anaconda fails to install with DVD
F10 anaconda fails to install with DVD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 19:14 EST by Jean-Marie White
Modified: 2008-12-03 12:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 10:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty3 (50.27 KB, image/jpeg)
2008-12-03 01:38 EST, Jean-Marie White
no flags Details
tty4 (87.79 KB, image/jpeg)
2008-12-03 01:39 EST, Jean-Marie White
no flags Details

  None (edit)
Description Jean-Marie White 2008-11-28 19:14:09 EST
Description of problem:
Anaconda fails to install from DVD.  It fails to validate the DVD.  I have burned 2 DVDs with K3b and validated them after burning them.  They are both readable on other machines, so I'm pretty sure my DVDs are fine.

If I hit choose to skip the media check and hit continue, anaconda fails:

"Running anaconda 11.4.1.62, the Fedora system installer - please wait...
exec of anaconda failed: Input/output error
install exited abnormally [1/1]
disabling swap...
unmounting filesystems...
/mntruntime done
disabling /dev/loop0 LOOP_CLR_FD failed: 16
/proc done
/dev/pts done
/sys done
/mnt/stage2 done
/selinux done
sending termination signals... done
sending kill signals ... done
you may safely reboot your system"

Version-Release number of selected component (if applicable):
11.4.1.62

How reproducible:
Happens every time.  Can't install Core 10.

Steps to Reproduce:
1. Burn Core 10 on DVD
2. Attempt to install (option 1)
3. When prompted to check media, accept.  Media check will fail.
  
Actual results:


Expected results:


Additional info:
My system is a dual Athlon MP 1500. It has 2 hard drives (on ext2, another one xfs).  It also has a CD-ROM and DVD-ROM. I'm running the latest bios 1.05.  I tried disabling ACPI in the bios.  Did not help.
Comment 1 Jean-Marie White 2008-11-29 15:48:38 EST
I decided to install Fedora Core 9 instead.  (I was running core 7).  It worked great.  I used the same k3b program (from core 7), the same DVD burner and a DVD from the same spool.  So, I'm pretty convinced that my install problem is not due to a faulty DVD.
Comment 2 Chris Lumens 2008-12-02 10:00:57 EST
Are there any error messages on tty3 or tty4 when this happens?  You can see those with alt-f4 and alt-f5.  Additionally, are you trying i386 DVDs on an x86-64 machine?
Comment 3 Jean-Marie White 2008-12-03 01:38:39 EST
Created attachment 325489 [details]
tty3

When I run the media check test, it fails ("The image which was just tested has errors...".  I've captured the tty3 output.
Comment 4 Jean-Marie White 2008-12-03 01:39:20 EST
Created attachment 325490 [details]
tty4
Comment 5 Chris Lumens 2008-12-03 10:00:26 EST
Perhaps the problem then is that you burned them at too fast a speed for the reader in the machine you're trying to install to?  We've definitely seen issues like that before.  Sadly, there's not really anything we can do here.  For whatever reason, your DVD that worked fine in another machine just isn't liked by the kernel on the second machine.
Comment 6 Jean-Marie White 2008-12-03 12:15:42 EST
Well, you can close the bug.  But I just wanted to re-iterate that all DVDs (Fedora Core 7, 9 and 10) were burned on the same machine that I was trying to upgrade to Core 10. (there is no "other machine") When Core 10 failed to upgrade, I decided to burn core 9 and that worked.  So, what I'm saying is that something changed between core 9 and 10 that makes my hardware to fail to correctly read the core 10 DVD.  (It's possible that the Core 10 DVD might have been corrupted, but I burned 2 of them, and ran the "verify ISO image" option in k3b.  So I'm pretty confident that both Core 10 DVDs are not bad.)

Note You need to log in before you can comment on or make changes to this bug.