Bug 473514 - LiveCD (on usb) ate an existing encrypted partition
LiveCD (on usb) ate an existing encrypted partition
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 20:27 EST by Stephen
Modified: 2013-01-09 23:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 08:47:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blkid, vol_id (4.41 KB, text/plain)
2008-12-03 20:21 EST, Stephen
no flags Details

  None (edit)
Description Stephen 2008-11-28 20:27:38 EST
Description of problem:

Before upgrading from F9 to F10 I made a bootable USB flash drive with the live CD, just to make sure it works and I have a fallback.

Boot into F10 on the thumb drive. Seems to work fine.

Reboot back into F9 and upon startup it fail to accept the password to unlock an encrypted partition which the F9 installer originally created.

I'm 100% sure the password is correct as due to the pre-F9 existing partitioning scheme I get asked for the password twice on startup -- once for swap and once for /home.

After 4 or 5 goes of 3 chances each it gave up on the first partition (which turned out to be swap, thank goodness), and asked for the password for /home, which it accepted.

So in the brief 10 mins I was booted into the F10 live-CD-on-USB, during which time I didn't explicitly mount any disks, it ate a partition.
Comment 1 Jeremy Katz 2008-12-01 13:01:26 EST
We turn on all swaps, but we don't run mkswap.  What's the output of 
  blkid -t TYPE=swap -o device
?
Comment 2 Stephen 2008-12-01 13:41:16 EST
$ /sbin/blkid -t TYPE=swap -o device
/dev/mapper/luks-VolGroup00-LogVol01
Comment 3 Jeremy Katz 2008-12-03 11:29:08 EST
I've tried setting up a reproducer here and I can't make this happen.  The only thing I can think of would be if somehow, it looked enough like a swap partition that blkid said the base device was a swap and then swapon was also happy enough with it to enable it.
Comment 4 Karel Zak 2008-12-03 18:16:26 EST
Strange. Please, try:

  /sbin/blkid  <the-device>
  /lib/udev/vol_id <the-device>

.. theoretically it's possible that you have (had) two headers (luks and swap) on the same device. Did you active used the LUKS device?
Comment 7 Stephen 2008-12-03 20:21:42 EST
Created attachment 325622 [details]
blkid, vol_id

I originally partitioned this laptop around F5 timeframe. Since then it's been upgrades until F9, which I installed fresh from the live-CD (although no repartitioning). When installing F9 I enabled encryption for /home and swap, left / unencrypted. F9 is what's still installed.

So, swap was definately used as swap for some time. And then for the last 6 months it's been used as encrypted swap. I've been using encrypted swap for the last 6 months without problems, typing the passord in twice on each boot.

Here's the output of the above commands, plus fdisk, vgdisplay and fstab. (I'll attach also in case the formatting gets chewed up):




$ blkid /dev/VolGroup00/LogVol0*

/dev/VolGroup00/LogVol00: LABEL="Fedora-9-Live-i6" UUID="1e823470-4f9f-490b-b5b6-65ea3d084c5e" TYPE="ext3"
/dev/VolGroup00/LogVol01: UUID="c081c58a-2230-4a78-b458-926c402f7393" TYPE="swap" 
/dev/VolGroup00/LogVol02: UUID="793c4033-e138-4e8f-af71-e0ec5654f19d" TYPE="crypt_LUKS" 


$ /lib/udev/vol_id /dev/VolGroup00/LogVol00

ID_FS_USAGE=filesystem
ID_FS_TYPE=ext3
ID_FS_VERSION=1.0
ID_FS_UUID=1e823470-4f9f-490b-b5b6-65ea3d084c5e
ID_FS_UUID_ENC=1e823470-4f9f-490b-b5b6-65ea3d084c5e
ID_FS_LABEL=Fedora-9-Live-i6
ID_FS_LABEL_ENC=Fedora-9-Live-i6
ID_FS_LABEL_SAFE=Fedora-9-Live-i6

$ /lib/udev/vol_id /dev/VolGroup00/LogVol01

ID_FS_USAGE=other
ID_FS_TYPE=swap
ID_FS_VERSION=2
ID_FS_UUID=c081c58a-2230-4a78-b458-926c402f7393
ID_FS_UUID_ENC=c081c58a-2230-4a78-b458-926c402f7393
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

$ /lib/udev/vol_id /dev/VolGroup00/LogVol02

ID_FS_USAGE=crypto
ID_FS_TYPE=crypto_LUKS
ID_FS_VERSION=2
ID_FS_UUID=793c4033-e138-4e8f-af71-e0ec5654f19d
ID_FS_UUID_ENC=793c4033-e138-4e8f-af71-e0ec5654f19d
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=



$ fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcccdcccd

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1275    10241406    7  HPFS/NTFS
/dev/sda3            1276        9729    67906755    5  Extended
/dev/sda5            1276        1288      104391   83  Linux
/dev/sda6            1289        9729    67802301   8e  Linux LVM

Disk /dev/dm-0: 8589 MB, 8589934592 bytes
255 heads, 63 sectors/track, 1044 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000


Disk /dev/dm-1: 58.6 GB, 58653147136 bytes
255 heads, 63 sectors/track, 7130 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x08020000


Disk /dev/dm-2: 2147 MB, 2147483648 bytes
255 heads, 63 sectors/track, 261 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x08020000


Disk /dev/dm-3: 58.6 GB, 58652618752 bytes
255 heads, 63 sectors/track, 7130 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000


$ vgdisplay

  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol00
  VG Name                VolGroup00
  LV UUID                ex3VQc-XEK0-rQor-Vocl-qljz-gXWW-yXeNzw
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                8.00 GB
  Current LE             256
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0
   
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol02
  VG Name                VolGroup00
  LV UUID                Lgz7i4-r2f2-7YX1-ReON-2SEk-iYlc-0prZJN
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                54.62 GB
  Current LE             1748
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:1
   
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol01
  VG Name                VolGroup00
  LV UUID                G02z32-HuhI-CJfn-6foV-eE4z-B312-6spzX0
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                2.00 GB
  Current LE             64
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:2


$ cat /etc/fstab

/dev/VolGroup00/LogVol00 /                       ext3    defaults,commit=360        1 1
/dev/mapper/luks-VolGroup00-LogVol02 /home                   ext3    defaults,commit=360        1 2
UUID=1faad3ca-517a-44d4-bcc8-6a59c80a4a07 /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/mapper/luks-VolGroup00-LogVol01 swap                    swap    defaults        0 0
tmpfs                   /tmp                tmpfs   defaults        0 0
Comment 8 Karel Zak 2009-10-22 08:47:46 EDT
The problem should be fixed in F-11 and F-12 where mkswap and cryptsetup zap old signatures and lilbblkid does not return ambivalent results. Closing.

Note You need to log in before you can comment on or make changes to this bug.