Bug 473515 - Morse code artifacts below text in abiword (with Desktop Effects on)
Morse code artifacts below text in abiword (with Desktop Effects on)
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: intel-gem
  Show dependency treegraph
Reported: 2008-11-28 20:51 EST by Stephen
Modified: 2009-12-04 12:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-04 12:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Shows corruption on screen and xorg log (326.67 KB, image/png)
2008-11-28 20:51 EST, Stephen
no flags Details
Xorg.0.log (104.54 KB, text/plain)
2008-12-06 01:18 EST, Stephen
no flags Details

  None (edit)
Description Stephen 2008-11-28 20:51:22 EST
Created attachment 325059 [details]
Shows corruption on screen and xorg log

Description of problem:

Just tried the F10 liveCD (on a stick) before upgrading to see if it all works and noticed that while typing into abiword black morse code artifacts are appearing underneath all the letters. Shading and unshading the window clears things up. Deleting or typing more brings back the artifacts.

Desktop Effects was enabled at the time, with desktops on a cube but no wobbling.

This is an all intel i915gm laptop.

I'll attach a screenshot.

Version-Release number of selected component (if applicable):

Whatever ships on the F10 lived CD.
Comment 1 Matěj Cepl 2008-11-29 05:03:40 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Stephen 2008-11-29 16:28:55 EST
This is the F10 live CD, there is no xorg.conf (or if there is, it's standard).
Comment 3 Matěj Cepl 2008-12-01 19:26:04 EST
well, but log file should be available -- if not as /var/log/Xorg.0.log then in /tmp directory.
Comment 4 Stephen 2008-12-06 01:18:06 EST
Created attachment 325966 [details]

I've installed from liveCD to hard drive and the problem persists, so attached is the Xorg.0.log file.

I noticed abiword was in the pending updates but that hasn't fixed it.

I also noticed that the corruption only occurs when Desktop Effects is enabled.

When typing a line of text the corruption occurs. Pressing return once to move to the next line makes no change. Pressing return again to leave a blank line between the text and the cursor seems to cause that area of the screen to be redrawn and the corruption is gone. Start typing text and it's back again...
Comment 5 Vedran Miletić 2009-11-05 18:11:47 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, including Intel driver, which may have resolved this issue.
To be more precise, Intel has undergone a major rewrite during Fedora 10, 11 and 12 cycles, and whole driver is working a lot better now. Users who have experienced this problem are encouraged to retry with at least Fedora 12 Beta and see if the issue is still relevant.

Please, if you experience this problem on Fedora 12 Beta or up-to-date system running Rawhide, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

We hope to see how many older bugs in Intel driver are still relevant today, in hope that most of them were fixed in rewrite process.

[This is a bulk message for all open Fedora 10 i810-related bugs (39 of them are still open). I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 6 Bug Zapper 2009-11-18 04:03:14 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 7 Vedran Miletić 2009-12-04 12:57:02 EST
Thank you for your bug report.

We are sorry, but the Fedora Project is will soon stop longer releasing bug fixes or any other updates for this version of Fedora. There were so many changes between Fedora 10 and Fedora 12 in Intel driver and X.Org that it's very likely that this bug is fixed. This bug will be set to CLOSED:WONTFIX to reflect this, but please reopen it if the problem persists after upgrading to the latest version of Fedora (version 12), which is available from:


Note You need to log in before you can comment on or make changes to this bug.