Bug 473533 - [radeon KMS] Starting KDE on Fedora 10 without nomodeset locks up system
[radeon KMS] Starting KDE on Fedora 10 without nomodeset locks up system
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 00:39 EST by John Griffiths
Modified: 2008-12-05 09:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 09:21:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2008-11-29 00:39:30 EST
Description of problem:
Starting KDE on Fedora 10 x86_64 locks up system. Loggin in from the greeter to use KDE or from a tty after starting X and the running startkde, the system stops.

Version-Release number of selected component (if applicable):
kdebase-4.1.3-2.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to log in to KDE session
2.
3.
  
Actual results:
The login starts, then the Fedora 10 boot screen appears and the progrss bar moves for about 5 seconds and then all activity stops. There is no drive activity and trying to switch to another tty with ctl-alt-f2 f3 etc does nothing.

Expected results:
KDE should start.

Additional info:
Comment 1 Kevin Kofler 2008-11-29 00:44:43 EST
What graphics hardware / driver?
Comment 2 John Griffiths 2008-11-29 12:04:00 EST
Sapphire using ATI R430 Radeon X800 XL PCIe
Comment 3 Kevin Kofler 2008-11-29 12:24:23 EST
Try booting the system with the nomodeset parameter (hold down some key to get GRUB to show up, then use e twice to edit the kernel command line and add nomodeset).
Comment 4 John Griffiths 2008-11-29 22:38:24 EST
That worked. I see from google there were some comments about that during beta, but I did not find bug when I searched. Sorry for the dup.

By the way, this happens on i386 Fedora 10, too. I switched back to the i386/i686PAE kernel because the x86_64 kept locking up and it was a pain to have to load both the x86_64 and the i386 libraries and applications. I found that Firefox 64 bit would not run some of the plugins like flash and Adobe reader plugin.Then NetBeans 6.5 would not run; I have to have that with the Sun JDK, so I bailed on 64 bit. There just does not seem to be the interest, community, or something to get it mature enough yet.

Seems the ATI driver is a bit slow to mature, too. 

But there is a lot of work in Fedora at all levels and I appreciate it greatly.
Comment 5 Matěj Cepl 2008-12-05 09:21:07 EST

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.