Bug 47356 - Autopartitioner wants to create 20 partitions, then aborts.
Autopartitioner wants to create 20 partitions, then aborts.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-04 22:58 EDT by Sam Varshavchik
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 11:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback (697 bytes, text/plain)
2001-07-04 22:59 EDT, Sam Varshavchik
no flags Details
Existing disk partition table before installation starts. (700 bytes, text/plain)
2001-07-04 23:08 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2001-07-04 22:58:29 EDT
The autopartitioner is having a major headache trying to deal with my
dual-boot laptop.  Eventualyl I get to blow up.  It has a 3Gb hard disk,
and the laptop carries 80Mb ram.

I run a text mode install, and tell it to delete all existing Linux
partitions.  I'm going to start from scratch.

Autopartitioning comes up like this:

hda1 - vfat - 515Mb (existing Win95 partition)
hda2 - extended partition
hda5 - vfat - 515Mb (existing Win95 partition)
  hda6 - ext3 - 1098Mb
  hda7 - swap - 94Mb
  hda8 - ext3 - 51Mb
  hda9 - ext3 - 657Mb

hda3 - ext3 3Mb    /

The swap is insufficient. With 80Mb RAM I need at least a 160Mb swap slice.

I don't know where hda3 came from.  It shows up as a one-cylinder
partition, 3Mb.  Maybe a bios glitch.  On top of that, only hda3 has a
mount point assigned to it by the autopartitioner, all the other partition
do not have mount points, and it is not clear what autopartitioning
intended them to be.

Obviously, a 3Mb root partition isn't very useful.  So I highlight it, then
select "Edit".

Suddenly, the 3Mb partition becomes an 1100Mb partition.  The edit box
opens up, and "Size (MB)" field reads "1100" for this partition.  Close the
dialog, this is not going to work.

I'm going to try to delete this partition.  After pressing Delete, the
screen looks like this:

hda1 - vfat - 515Mb (existing Win95 partition)
hda2 - extended partition
hda5 - vfat - 515Mb (existing Win95 partition)
   hda6 - swap - 94Mb
   hda7 - ext3 - 51Mb
   hda8 - swap - 141Mb
   hda9 - ext3 - 51Mb
   hda10 - swap - 160Mb
   hda11 - ext3 - 51Mb
   hda12 - swap - 181Mb
   hda13 - ext3 - 51Mb
   hda14 - swap - 185Mb
   hda15 - ext3 - 51Mb
   hda16 - swap - 181Mb
   hda17 - ext3 - 51Mb
   hda18 - swap - 192Mb
   hda19 - ext3 - 51Mb     /boot
  Free space - 389Mb
Free space - 3Mb

Only hda19 now has an assigned mount point of /boot.

I hit Back to exit out of the autopartitioning screen, returning to the
screen where I choose to remove all existing linux partitions.  I enter
autopartitioning again, and it comes up with the first partitioning layout.
I edit the 3Mb hda3 partition again, and change its mount point to /tmp2,
for now.

I select hda6, get a python traceback.
I also get this traceback if I begin the text mode installer, and enter
autopartitioning for the first time, then select "hda6" (without trying to
delete hda3 first).
Comment 1 Sam Varshavchik 2001-07-04 22:59:06 EDT
Created attachment 22727 [details]
Anaconda traceback
Comment 2 Sam Varshavchik 2001-07-04 23:08:29 EDT
Created attachment 22728 [details]
Existing disk partition table before installation starts.
Comment 3 Sam Varshavchik 2001-07-04 23:10:08 EDT
Note that I do NOT have an hda3 partition when I run the installer.  It appears
out of thin air, and things pretty much go downhill from that point on.

Comment 4 Jeremy Katz 2001-07-06 00:44:36 EDT
Okay, I'm pretty sure I fixed this in the internal tree...  please reopen this
bug if you see it again in beta2 please.

Note You need to log in before you can comment on or make changes to this bug.