This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 473570 - Restore dejavu deps
Restore dejavu deps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-11-29 07:08 EST by Nicolas Mailhot
Modified: 2008-12-08 07:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 07:43:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-11-29 07:08:15 EST
Upstream now bundles dejavu in its windows-oriented installers.

Unfortunately the Fedora OO.o package has dropped its deps on dejavu.

That means documents created under windows OO.o with the bundled dejavu fonts won't work under Fedora in all cases. We're now inciting OO.o users to standardise on Arial and Times New Roman

Please put the DejaVu dependencies back

For Fedora 11, that would be one or several of

 dejavu-fonts-sans
 dejavu-fonts-sans-mono
 dejavu-fonts-serif
 dejavu-fonts-lgc-sans
 dejavu-fonts-lgc-sans-mono
 dejavu-fonts-lgc-serif
Comment 1 Caolan McNamara 2008-11-29 07:54:44 EST
I don't really want to require fonts that are not required to guarantee that the associated language of a langpack can at least be rendered, or are not "critical" fonts. I see the Liberation fonts as critical because they are the only fonts that we have that match the MS Times New Roman etc group and enable interoperable layout for MSOffice documents. I don't really see the dejavu fonts in the same light as "OOo really needs them to be sure to work" to enforce a requires on them
Comment 2 Nicolas Mailhot 2008-11-29 08:11:14 EST
As I wrote, not requiring DejaVu when it's installed in the windows version effectively negates the FLOSS advocacy efforts that went into making SUN bundle dejavu.

We're back to square one "Arial is the only font available on every system"

You say the Liberation fonts are critical, but that's a self-fulfilling profecy when no effort is made to make any FLOSS font a viable alternative (and we do not control Liberation, as it has to follow every change MS decides, and besides Liberation does not match the coverage of all the proprietary Arial or TNR variants out there)
Comment 3 Caolan McNamara 2008-12-01 18:17:00 EST
Well I'd disagree, but not sufficiently to go against the desire to have a requires on the dejavu family so I'll stick a requires in for dejavu-fonts-sans, dejavu-fonts-serif, dejavu-fonts-sans-mono. Does that fit what you want ?
Comment 4 Nicolas Mailhot 2008-12-02 01:56:53 EST
That would fit nicely. Thank you
Comment 5 Caolan McNamara 2008-12-08 07:43:01 EST
[caolan@Nom ~]$ rpm -q --requires openoffice.org-core | grep deja | xargs
dejavu-fonts-sans dejavu-fonts-sans-mono dejavu-fonts-serif
[caolan@Nom ~]$ rpm -q openoffice.org-core
openoffice.org-core-3.0.1-12.3.fc11.1.x86_64

Note You need to log in before you can comment on or make changes to this bug.