Bug 473571 - Possible Bug In Intel GM965 Xorg Drivers
Possible Bug In Intel GM965 Xorg Drivers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 07:40 EST by Sameer Naik
Modified: 2008-12-04 12:01 EST (History)
13 users (show)

See Also:
Fixed In Version: xorg-x11-drv-i810-2_5_0-4_fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 09:18:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (60.19 KB, text/plain)
2008-11-29 08:41 EST, Sameer Naik
no flags Details
Xorg.0.log.old (41.34 KB, text/plain)
2008-11-29 08:42 EST, Sameer Naik
no flags Details

  None (edit)
Description Sameer Naik 2008-11-29 07:40:11 EST
Description of problem:
I have a Acer Aspire 4720 Laptop with Intel GM965 Mobile Graphics Accelerator.
The Xorg.0.log throws the following error
(EE) AIGLX error: Calling driver entry point failed(EE) AIGLX: reverting to software rendering
Due to which i am unable to use "Desktop Effects". I was able to use the effects in Fedora 8.

Version-Release number of selected component (if applicable):
Fedora 10 with the latest updates from Fedora and RPM Fusion Respositories
* xorg-x11-drv-i810-2.5.0-3.fc10.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
"Desktop Effects" cannot be enabled

Expected results:
"Desktop Effects" are enabled

Additional info:
Heres the Xorg.0.log: http://pastebin.com/f15c5c562
Comment 1 Matěj Cepl 2008-11-29 08:04:43 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Sameer Naik 2008-11-29 08:41:28 EST
Created attachment 325084 [details]
Xorg.0.log
Comment 3 Sameer Naik 2008-11-29 08:42:22 EST
Created attachment 325085 [details]
Xorg.0.log.old
Comment 4 Sameer Naik 2008-11-29 08:44:02 EST
I have attached Xorg.0.log and Xorg.0.log.old to the bug report.
Also i do not have a /etc/X11/xorg.conf file, its currently in autodetect mode
Comment 5 Boris Devouge 2008-11-29 22:21:13 EST
Seeing the same thing on fedora 10 i386, on Lenovo x300 laptop with 4 gigs ram, kernel 2.6.27.7-130.fc10.i686.PAE and xorg-x11-drv-i810-2.5.0-3.fc10.i386.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Comment 6 vasilis 2008-12-01 06:27:46 EST
I have exactly the same error message with the Latitude E4300, with Intel 4500MHD
Comment 7 Michael Arsov 2008-12-01 14:17:55 EST
I also have the same problem. My laptop is DEll Inspiron 700m.
I did not have any issues when running Fedora 9 on it.

# glxinfo | grep direct
[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes

Now I downloaded and tried to compile manually xf86-video-intel-2.5.1, and I keep getting an error that xorg-server is not installed:

checking for XORG... configure: error: Package requirements (xorg-server xproto fontsproto ) were not met:
No package 'xorg-server' found


although I have installed xorg-x11-server-Xorg version 1.5.3-5.fc10

Does anyone have an update on this issue?

Thanks
Comment 8 David Moreno 2008-12-02 09:26:47 EST
Same problem here, Dell Optiplex with intel q35 graphics adapter.

glxinfo|grep direct command returns:

[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes

compiz --replace command returns:

intel_init_bufmgr:592] Error initializing buffer manager.
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

When trying to enable desktop effects in gnome, I get a white screen that stands for the security time and then return to normal behaviour.
Comment 9 mike 2008-12-02 12:13:53 EST
I get this same error with Intel 82845G chip...

(EE) AIGLX error: Calling driver entry point failed(EE) AIGLX: reverting to
software rendering
Comment 10 David Moreno 2008-12-02 12:17:12 EST
As additional info, in other computer ( laptop in this case ) which runs Fedora 10 as well, same driver but i810 display adaptor works fine:

glxinfo|grep direct
direct rendering: Yes

and compiz runs correctly.
Comment 11 leonardo 2008-12-03 06:12:12 EST
I got this very same problem with an HP 6720s. graphics provided by an Intel 965GME/GLE

same error when launching glxinfo and same error line present in Xorg.0.log

the problem appears only when using 2.6.27.7 vanilla kernel, but not with the distribution kernel-2.6.27.5-117.fc10.x86_64 (that unfortunately has others worst problems for me)
Comment 12 David Moreno 2008-12-03 06:31:03 EST
Actually the problem in my case appears with the distributed i386 kernel:

uname -a

Linux (edited)hostname 2.6.27.5-117.fc10.i686.PAE #1 SMP Tue Nov 18 12:08:10 EST 2008 i686 i686 i386 GNU/Linux

but it's true that I made a previous x86_64 installation and problem wasn't detected. I had to reinstall based on i386 due to spurious reasons and voilà !
Comment 13 Mark Watts 2008-12-03 15:36:04 EST
"Me too"

Fedora 10

Laptop - Fujitsu Lifebook P7010

$ compiz --indirect-rendering --replace
[intel_init_bufmgr:592] Error initializing buffer manager.
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

$ glxinfo | grep direct
[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes
Comment 14 rene 2008-12-03 17:28:32 EST
"Me too"

Fedora 10

Laptop - ASUS Z9200L

$ glxinfo | grep direct
[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes
Comment 15 rene 2008-12-03 17:31:58 EST
Fedora 10

Laptop - ASUS Z9200L

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02

$ glxinfo | grep direct
[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes
Comment 16 voodooo 2008-12-03 20:00:53 EST
Same here.

Thinkpad T500
Fedora 10
Linux-2.6.27.5-117.fc10.i686.PAE

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Cantiga Integrated Graphics Controller (rev 07)

glxinfo | grep direct
[intel_init_bufmgr:592] Error initializing buffer manager.
direct rendering: Yes
Comment 17 Dave Airlie 2008-12-03 20:05:03 EST
PAE and GEM together are busted, but it should fallback to the old codepaths fine, and work fine.

Please grab the mesa -14 from koji and see if it helps, and latest xorg-x11-drv-i810

it should fix all the fallbacks.
Comment 18 Boris Devouge 2008-12-03 20:29:55 EST
Fixes it for me.

Thank you.
Comment 19 Sameer Naik 2008-12-04 00:21:50 EST
Alright!
This worked for me as well

Got the packages from koji
Latest Xorg Drivers: http://koji.fedoraproject.org/koji/buildinfo?buildID=72777
Mesa 7.2-0.14 : http://koji.fedoraproject.org/koji/buildinfo?buildID=71402

And all desktop effects are in place.

Thanks
Comment 20 David Moreno 2008-12-04 02:37:30 EST
I upgraded mesa, glx and intel driver packages with these ones and now I can enable desktop effects.

Also I get now:

glxinfo|grep direct
direct rendering: Yes

Many thanks.
Comment 21 Mark Watts 2008-12-04 04:58:15 EST
These allow me to use Compiz now with no problems :)
Comment 22 voodooo 2008-12-04 08:42:39 EST
Worked for me to, everything working now.

Thanks.
Comment 23 Matěj Cepl 2008-12-04 09:18:50 EST
Thanks for letting us know!

Note You need to log in before you can comment on or make changes to this bug.