Bug 473575 - radeon driver produces glitches with Flash embeds in Gecko browsers
radeon driver produces glitches with Flash embeds in Gecko browsers
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 08:17 EST by Florian Fahr
Modified: 2008-12-16 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 18:07:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the described glitch (231.91 KB, image/png)
2008-11-29 08:17 EST, Florian Fahr
no flags Details
XServer config (831 bytes, text/plain)
2008-11-29 12:09 EST, Florian Fahr
no flags Details
XServer log file created during regular use (56.00 KB, text/plain)
2008-11-29 12:19 EST, Florian Fahr
no flags Details
nah, that's not it... (21.26 KB, text/plain)
2008-11-29 12:32 EST, Florian Fahr
no flags Details
xorg.conf-less log file (58.97 KB, text/plain)
2008-11-29 12:37 EST, Florian Fahr
no flags Details

  None (edit)
Description Florian Fahr 2008-11-29 08:17:46 EST
Created attachment 325083 [details]
Screenshot of the described glitch

Description of problem:
I'm using an r300 card (mobilityRadeon 9700) with a recently upgraded Fedora 10. On certain sites (example: http://www.vgcats.com/) Flash embeds get painted over with grey if you scroll them off-screen and they only get refreshed if there is an animation in that part of the embed or you drag a different window over it (see my attached screenshot). The VESA driver doesn't produce such glitches and the Opera browser doesn't seem to be affected (didn't have the opportunity to try WebKit, yet). Also disabling render acceleration didn't help. Also, there are certain sites which don't have this problem, perhaps because they only have a white background. The one site I know is http://www.failblog.org/ .

Version-Release number of selected component (if applicable):
6.9.0-54.fc10

How reproducible:
Always

Steps to Reproduce:
1. Open Firefox/Epiphany/Mozilla
2. Load www.vgcats.com
3. Scroll down to the mentioned Flash embed
  
Actual results:
The previously invisible parts are now covered in grey (see my attached screenshot).

Expected results:
The Flash embed should be perfectly visible.

Additional info:
Comment 1 Matěj Cepl 2008-11-29 10:54:07 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Florian Fahr 2008-11-29 12:09:20 EST
Created attachment 325094 [details]
XServer config

Deleting/Renaming this file didn't change anything.
Comment 3 Florian Fahr 2008-11-29 12:19:06 EST
Created attachment 325095 [details]
XServer log file created during regular use

Also note: Modifying the values for "RenderAccel" didn't do anything except for "XAA" freezing X (as expected).
Comment 4 Florian Fahr 2008-11-29 12:32:28 EST
Created attachment 325096 [details]
nah, that's not it...
Comment 5 Florian Fahr 2008-11-29 12:37:57 EST
Created attachment 325097 [details]
xorg.conf-less log file
Comment 6 Florian Fahr 2008-12-14 08:35:12 EST
Well, looks like this isn't a bug after all.

I just had to do a complete fresh install of Fedora 10, because GRUB had spazzed out leaving me no other option than wiping my system partition. Anyway, either you just released a fix at the same time or the issue only appeared on my system after upgrading. Anyway, this bug can be closed, now.
Comment 7 Matěj Cepl 2008-12-16 18:07:19 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.