Bug 473585 - jetty : Unowned directories
jetty : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jetty (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 10:40 EST by Michael Schwendt
Modified: 2009-05-26 03:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.1.15-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-25 08:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-29 10:40:31 EST
One or more directories are not included within this
package and/or its sub-packages:

=> jetty-5.1.14-1.6.fc10.i386 (rawhide-development-i386)
/var/cache/jetty
/var/lib/jetty
/usr/share/doc/jetty-5.1.14

=> jetty-javadoc-5.1.14-1.6.fc10.i386 (rawhide-development-i386)
/var/lib/jetty
/var/lib/jetty/webapps

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Fedora Update System 2009-01-06 16:55:37 EST
jetty-5.1.14-1.7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/jetty-5.1.14-1.7.fc10
Comment 2 Fedora Update System 2009-01-07 16:51:53 EST
jetty-5.1.14-1.7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jetty'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0294
Comment 3 Michael Schwendt 2009-02-01 09:38:10 EST
This ticket is about Rawhide, not Fedora 10!

In Rawhide there are still unowned directories, some of them due to incomplete inter-package dependencies:

=> jetty-5.1.14-1.7.fc11.src.rpm
=> jetty-5.1.14-1.7.fc11.i386 (rawhide)
/var/cache/jetty
/var/lib/jetty
/usr/share/doc/jetty-5.1.14
    provided by: jetty-manual-5.1.14-1.7.fc11.i386
/etc/init.d
    provided by: chkconfig-1.3.41-1.i386

=> jetty-5.1.14-1.7.fc11.src.rpm
=> jetty-javadoc-5.1.14-1.7.fc11.i386 (rawhide)
/var/lib/jetty
/var/lib/jetty/webapps
    provided by: jetty-5.1.14-1.7.fc11.i386
Comment 4 Jeff Johnston 2009-02-02 15:25:41 EST
(In reply to comment #3)
> This ticket is about Rawhide, not Fedora 10!
> 
> In Rawhide there are still unowned directories, some of them due to incomplete
> inter-package dependencies:
> 
> => jetty-5.1.14-1.7.fc11.src.rpm
> => jetty-5.1.14-1.7.fc11.i386 (rawhide)
> /var/cache/jetty
> /var/lib/jetty
> /usr/share/doc/jetty-5.1.14
>     provided by: jetty-manual-5.1.14-1.7.fc11.i386
> /etc/init.d
>     provided by: chkconfig-1.3.41-1.i386
> 
> => jetty-5.1.14-1.7.fc11.src.rpm
> => jetty-javadoc-5.1.14-1.7.fc11.i386 (rawhide)
> /var/lib/jetty
> /var/lib/jetty/webapps
>     provided by: jetty-5.1.14-1.7.fc11.i386

I have rebuilt a 1.8 version after finding a script that tests for unowned directories and files.  The 1.8 rpm passes on my F-10 system after being installed.  The rawhide rpm was also built using the same spec file.

I am not sure why you are flagging chkconfig above since it is in the Requires for the main package.  FWIW: I made the javadoc and manual subpackages require the main package and I made the main package own /var/cache/jetty /var/lib/jetty and /usr/share/doc/jetty-5.1.14.
Comment 5 Michael Schwendt 2009-02-03 05:07:57 EST
chkconfig is in the results, because you use /etc/init.d instead of %{_initrddir}:

  $ rpm --eval %{_initrddir}
  /etc/rc.d/init.d

/etc/init.d is not a directory, it's just a symlink to a directory. So far, the "provided by" lines are only hints, to show whether any other pkg in the repos provides a path. In some cases, this reveals conflicts between a file/symlink and a directory.
Comment 6 Fedora Update System 2009-02-04 21:14:11 EST
jetty-5.1.14-1.8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jetty'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1280
Comment 7 Jeff Johnston 2009-02-06 15:13:33 EST
(In reply to comment #5)
> chkconfig is in the results, because you use /etc/init.d instead of
> %{_initrddir}:
> 
>   $ rpm --eval %{_initrddir}
>   /etc/rc.d/init.d
> 
> /etc/init.d is not a directory, it's just a symlink to a directory. So far, the
> "provided by" lines are only hints, to show whether any other pkg in the repos
> provides a path. In some cases, this reveals conflicts between a file/symlink
> and a directory.

Ok, I have just pushed a new rpm that contains this fix as well.
Comment 8 Fedora Update System 2009-02-07 17:21:48 EST
jetty-5.1.14-1.9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jetty'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1469
Comment 9 Michael Schwendt 2009-04-01 09:12:13 EDT
In the package files list a new unowned dir is found:

=> jetty-5.1.14-2.10.fc11.src.rpm
=> jetty-5.1.14-2.10.fc11.i586 (rawhide)
/var/lib/jetty/lib

[...]

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^jetty
Comment 10 Jeff Johnston 2009-04-07 17:06:45 EDT
(In reply to comment #9)
> In the package files list a new unowned dir is found:
> 
> => jetty-5.1.14-2.10.fc11.src.rpm
> => jetty-5.1.14-2.10.fc11.i586 (rawhide)
> /var/lib/jetty/lib
> 
> [...]
> 
> The script to find unowned directories is not complete yet, but
> still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
> $ ./dircheck-remote.py -r rawhide -n ^jetty  

Is there a way to use this script on a local rpm build (i.e. to make sure it is ok before pushing it to rawhide)?
Comment 11 Michael Schwendt 2009-04-08 03:44:14 EDT
It accepts an arbitrary number of -r arguments which you can use to point it to a local repository in addition to rawhide.
Comment 12 Fedora Update System 2009-04-23 12:13:14 EDT
jetty-5.1.14-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/jetty-5.1.14-3.fc10
Comment 13 Fedora Update System 2009-05-22 15:29:01 EDT
jetty-5.1.15-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/jetty-5.1.15-3.fc10
Comment 14 Fedora Update System 2009-05-26 03:57:00 EDT
jetty-5.1.15-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.