Bug 4736 - Xwindows fails to start
Xwindows fails to start
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
http://www.redhat.com/cgi-bin/support...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-26 21:26 EDT by lee
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-26 21:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lee 1999-08-26 21:26:29 EDT
Date sent:      	Thu, 26 Aug 1999 19:51:08 -0400
To:             	lee@designwest.com
From:           	support@redhat.com
Subject:        	Configuring and running Xwindows
[Incident:support 990813-0045]

Recently you requested personal assistance from our on-line
support center. Below is a summary of your request and our
response.

If we do not hear from you within 48 hours we will assume
your
issue has been resolved.

Thank you for allowing us to be of service to you.
------------------------------------------------------------
-

SUMMARY:  Configuring and running Xwindows
SUGGESTED SOLUTION:
At 8/16/99 6:41 PM we wrote -
Hi,

You should be able to configure X without a problem. Did you
change
any hardware. What occurs when you try torun X? Also, you
may want
to try this command startx &> start.log and review the log
on why X
is failing.

Thanks.

At 8/25/99 6:26 PM we wrote -
Can you please indicate to me on what kind of videocard you
have
or/and what chipset?

Thanks.

At 8/26/99 5:54 PM we wrote -
Have you attempted to simply try to reinstall. The
E-Commerce is
nnothign more then the regular box set with some added
components.
Xfree86 and hardware support is all the same. If possible,
please
try to reinstall and reconfig X.

Thanks.

At 8/26/99 7:48 PM we wrote -
Have you checked the permissions of your
/etc/X11/xinit/Xclients? It
should be -rwxr-xr-x   1 root     root         2052 Apr 19
12:55
Xclients

If it is that. I would like to refer you to
http://developer.redhat.com and report your problem as a
bug. Please
be sure to state that X does work upon installation. and
that you
are able to configure it fine when you isntalled the
standard 6.0
version. Thank you. And I apologize I am not able to be of
more
service. When you submit your bug report. It will go to a
developer
to take a look at your problem.

Thanks.

INCIDENT DETAILS:
         Reference #:  990813-0045
             Product:  Red Hat Linux 6.0
            Category:  Installation
        Contact info:  lee@designwest.com
        Time created:  8/13/99 10:44 AM
        Last updated:  8/26/99 7:50 PM
        Elapsed time:  13 Days, 9 Hours
              Status:  Unresolved
        Registration:  7af9aa08c2010395

DESCRIPTION:
I originally installed RH 6.0 standard edition without any
problems.
 I've now done a clean load (wiped the hard drives) of the
Linux
e-commerce server.  Whereas with my original config I had no
problems with x windows, NOW they don't even work!  I have
ran
Xconfigurator a number of times and then tried startx but it
keeps
bombing out.

What am I forgetting, or is there something deeper and more
sinster
involved?At 8/24/99 1:29 AM you wrote - No hardware has been
changed, and I have configured X with no problems on my non
ecommerce machine without any problems.....

Here is the start log for the Xserver:

_X11TransSocketUNIXConnect: Can't connect: errno = 111
waiting for X server to begin accepting connections
XFree86 Version 3.3.3.1 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 4 1999
 If the server is older than 6-12 months, or if your card is
newer
 than the above date, look for a newer version before
reporting
 problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-15smp i686 [ELF]
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 0):
      NV1, STG2000, RIVA128, RIVATNT, ET4000, ET4000W32,
ET4000W32i,
      ET4000W32i_rev_b, ET4000W32i_rev_c, ET4000W32p,
ET4000W32p_rev_a,
      ET4000W32p_rev_b, ET4000W32p_rev_c, ET4000W32p_rev_d,
ET6000,
ET6100,
      et3000., pvga1, wd90c00, wd90c10, wd90c30, wd90c24,
wd90c31,
wd90c33,
      gvga, ati, sis86c201, sis86c202, sis86c205, sis86c215,
sis86c225,
      sis5597, sis5598, sis6326, tvga8200lx, tvga8800cs,
tvga8900b,
      tvga8900c, tvga8900cl, tvga8900d, tvga9000, tvga9000i,
tvga9100b,
      tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi,
tgui9430dgi,
      tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
tgui9685,
      cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
3dimage975,
      3dimage985, clgd5420, clgd5422, clgd5424, clgd5426,
clgd5428,
      clgd5429, clgd5430, clgd5434, clgd5436, clgd5446,
clgd5480,
clgd5462,
      clgd5464, clgd5465, clgd6205, clgd6215, clgd6225,
clgd6235,
clgd7541,
      clgd7542, clgd7543, clgd7548, clgd7555, clgd7556,
ncr77c22,
ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP,
mgag200,
      mgag100, oti067, oti077, oti087, oti037c, al2101,
ali2228,
ali2301,
      ali2302, ali2308, ali2401, cl6410, cl6412, cl6420,
cl6440,
video7,
      ark1000vl, ark1000pv, ark2000pv, ark2000mt, mx,
realtek,
s3_virge,
      AP6422, AT24, AT3D, s3_svga, NM2070, NM2090, NM2093,
NM2097,
NM2160,
      NM2200, ct65520, ct65525, ct65530, ct65535, ct65540,
ct65545,
ct65546,
      ct65548, ct65550, ct65554, ct65555, ct68554, ct69000,
ct64200,
      ct64300, mediagx, V1000, V2x00, p9100, spc8110,
generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default
values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) SVGA: Graphics device ID: "My Video Card"
(**) SVGA: Monitor ID: "Generic Multisync"
(--) SVGA: Mode "1280x1024" needs hsync freq of 64.25 kHz.
Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 70.24 kHz.
Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 70.88 kHz.
Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 74.59 kHz.
Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 75.00 kHz.
Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 76.01 kHz.
Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freqof 78.86 kHz.
Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 80.21 kHz.
Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 81.13 kHz.
Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 87.50 kHz.
Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 89.62 kHz.
Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 91.15 kHz.
Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 93.75 kHz.
Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz.
Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz.
Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz.
Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz.
Deleted.
(**) FontPath set to "unix/:-1"
(--) SVGA: PCI: S3 ViRGE/DX or /GX rev 1, Memory @
0xdc000000
(--) SVGA: S3V: ViRGE/DXGX rev 1, Linear FB @ 0xdc000000
(--) SVGA: Detected S3 ViRGE/DXGX
(--) SVGA: using driver for chipset "s3_virge"
(--) SVGA: videoram:  4096k
(--) SVGA: Ramdac speed: 170 MHz
(--) SVGA: Detected current MCLK value of 69.801 MHz
(--) SVGA: chipset:  s3_virge
(--) SVGA: videoram: 4096k
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 170.000 MHz
(**) SVGA: Mode "800x600": mode clock =  69.650
(--) SVGA: Virtual resolution set to 800x600
(--) SVGA: SpeedUp code selection modified because virtualX
!= 1024
(--) SVGA: s3_virge: Using hardware cursor
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: 8x8 pattern fill
(--) SVGA: XAA: 8x8 color expand pattern fill
(--) SVGA: XAA: CPU to screen color expansion (bitmap,
TE/NonTE
imagetext, TE/NonTE polytext)
(--) SVGA: XAA: Using 6 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and non-transparent stipples
(--) SVGA: XAA: Horizontal and vertical lines and segments

/etc/X11/xinit/xinitrc: /etc/X11/xinit/Xclients: Permission
denied
exec: /etc/X11/xinit/Xclients: cannot execute: Permission
denied
waiting for X server to shut down
At 8/25/99 6:49 PM you wrote - A PCI S3 Virge DX video card.
 It
hasn't changed since my first installation of RH 6.0 and the
present
installation of the E-commerce edition.At 8/26/99 6:05 PM
you wrote
- Actually I have reinstalled the entire package (Red Hat
E-commerce
6.0) X2, without any resolution.
At 8/26/99 6:09 PM you wrote - Actually I have reinstalled
the
entire package (Red Hat E-commerce 6.0) X2, without any
resolution.
And while the tests during installation worked (the
installation
program was able to bring up Xwindows in the testing section
without
difficulty), upon completion of the load does this happen.
If you take a look at the start.log above you will see:

/etc/X11/xinit/xinitrc: /etc/X11/xinit/Xclients: Permission
denied
   exec: /etc/X11/xinit/Xclients: cannot execute: Permission
denied

This, to me, gives the best clue as to the problem.
Especially
since this did not occur when I installed, on the same
server, the
non-commerce version of RH 6.0.  Have you really checked the
relationship of the added components to xwindows?

Also if your suggesting reloading only Xwindows...fine but
please
give me a list of the component rpms, so I don't have to go
through
the complete reinstallation a third time.

If your issue remains unresolved, please update your
incident at
http://www.redhat.com/cgi-bin/support?r&11-990813-0045&100-9
34555470


------------------------------------------------------------
---
Comment 1 Preston Brown 1999-08-26 21:42:59 EDT
please get xinitrc-2.4.1-1.noarch.rpm from
ftp://ftp.redhat.com/redhat/updates/6.0/noarch.

Note You need to log in before you can comment on or make changes to this bug.