Bug 473600 - [Regression] Screen brightness problems on Acer laptop
[Regression] Screen brightness problems on Acer laptop
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-29 11:53 EST by Rohan Dhruva
Modified: 2010-03-21 15:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-24 23:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 563165 None None None Never
Launchpad 304940 None None None Never

  None (edit)
Description Rohan Dhruva 2008-11-29 11:53:13 EST
Description of problem:
I just installed F10 on my Acer TravelMate 3260 laptop. The ACPI stuff like bluetooth, screen brightness etc. is handled by acer-wmi module. In Fedora 9, brightness control worked perfectly. In Fedora 10, I am having the problems with both control of brightness in preferences, and the on-screen display which appears when I change brightness using the Fn+Arrow keys. The problem is described in detail below.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. In g-p-m Preferences, "On AC Power", Set display brightness to XX% doesn't work
2. Control brightness using Fn+Left/Right arrow keys, OSD shoots beyond max and min limits
Actual results:
1. The brightness does not reduce/increase
2. The OSD fill increases even after full brightness, and decreases even after zero

Expected results:
1. Change should take place instantly
2. OSD fill limits should be between actual limits of brightness only

Additional info:
I can control brightness software-"manually" from the console, by manually writing and reading entries from /sys/devices/platform/acer-wmi/backlight/acer-wmi. Here is sample output:

[rohan@fedora acer-wmi]$ pwd
[rohan@fedora acer-wmi]$ cat max_brightness 
[rohan@fedora acer-wmi]$ cat actual_brightness 
[rohan@fedora acer-wmi]$ echo 5 | sudo tee brightness 
[rohan@fedora acer-wmi]$ cat brightness 
[rohan@fedora acer-wmi]$ cat actual_brightness 
[rohan@fedora acer-wmi]$
Comment 1 Rohan Dhruva 2008-11-29 11:56:55 EST
This output might be helpful:

[rohan@fedora ~]$ lshal | grep laptop_panel
  info.capabilities = {'laptop_panel'} (string list)
  info.category = 'laptop_panel'  (string)
  laptop_panel.access_method = 'general'  (string)
  laptop_panel.num_levels = 16  (0x10)  (int)
Comment 2 Rohan Dhruva 2008-12-03 16:33:17 EST
I could reproduce this exact same bug on Ubuntu 8.10 livecd which uses GNOME 2.24 too. Hence I concluded that this might be an upstream bug, and filed one here - http://bugzilla.gnome.org/show_bug.cgi?id=563165
Comment 3 Rohan Dhruva 2008-12-09 16:49:46 EST
This is something I noticed of Fedora 10 - whenever I change the brightness using the keyboard (Fn-Left/Right Arrow) key, I get this message in dmesg:

[rohan@fedora Shared]$ dmesg
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: non-query interrupt received, switching to interrupt mode

This happens regardless whether acer_wmi module is loaded or unloaded. Could this be indicative of some problem, or is it harmless?
Comment 4 Jafaruddin Lie 2009-02-08 23:57:43 EST
Same thing on Fedora 10, Acer Travelmate 6492.
The symptom is as described by Rohan.
Comment 5 Rohan Dhruva 2009-02-25 04:59:25 EST
Update: I tried reproducing this situation on recently released Debian lenny, and there the indicator and slider works perfectly. Debian has g-p-m 2.22.1.
Comment 6 Rohan Dhruva 2009-03-05 08:00:32 EST
The exact same problem exists in Fedora 11 Alpha and Ubuntu 9.04 Alpha 5, so I
am prompted to think it is a gnome 2.24 and 2.26 problem.
Comment 7 Richard Hughes 2009-04-15 11:59:49 EDT
Does this still happen with the version in fedora rawhide, or the version of the Fedora 11 beta live cd?
Comment 8 Rohan Dhruva 2009-04-17 10:03:26 EDT
Hi Richard,

I am on the live system of Fedora 11 snap1. I can confirm that this bug is definitely solved, the increments in the OSD are proper, and g-p-m settings change apply instantly.

Is the fix local to fedora, or would it work on other distributions like Ubuntu?

Thanks a lot.
Comment 9 Matthias Clasen 2009-04-24 23:31:17 EDT
Ok, closing this then.
Comment 10 Fernando Mansito 2009-11-08 03:50:34 EST
I have purchased an Acer Aspire AS-3810T 354G32N and installed Centos (presently 5.4). I already have an Acer TravelMate C112TCI with the same Centos installation.

In none of the two computers do the Fn-direction keyboard keys RIGHT and LEFT work. Those are the ones that set screen brightness. On the 3810T that is a serious problem due to the extremely bright screen that Linux is showing.

I am writing from the 3810T and these are my kernel brightness documented scripts and uname outputs:


[root@aspire scripts]# chmod 755 *brightness
[root@aspire scripts]# ./*get-bright*
Missing or empty environment variable(s).
This script should be started by hald.
[root@aspire scripts]# cd linux
[root@aspire linux]# ls
hal-luks-remove-linux                hal-system-power-hibernate-linux
hal-luks-setup-linux                 hal-system-power-reboot-linux
hal-luks-teardown-linux              hal-system-power-set-power-save-linux
hal-system-lcd-get-brightness-linux  hal-system-power-shutdown-linux
hal-system-lcd-set-brightness-linux  hal-system-power-suspend-linux
[root@aspire linux]# ./*get-bright*
No ACPI method found
[root@aspire linux]# 
[root@aspire linux]# uname -a
Linux aspire.workgroup 2.6.18-164.6.1.el5.centos.plusPAE #1 SMP Wed Nov 4 10:17:55 EST 2009 i686 i686 i386 GNU/Linux
[root@aspire linux]# 


Thanks for your help
Comment 11 Fernando Mansito 2010-03-21 15:36:27 EDT
I found a solution that works for the Aspire 3810T and, I hope, for others, the merit of an anonymous expert. Please find it at CentOS Issue ID 004246, URL


It writes a brightness level directly to a register of the pci VGA device.

I see this bug was closed. Was another solution already posted, or was it an error? One continues to find more complaints over several Linux distros and Acer computer models.

Best regards to all
fernando mansito

Note You need to log in before you can comment on or make changes to this bug.