Bug 473641 - collectd : Unowned directories
collectd : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: collectd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 13:47 EST by Michael Schwendt
Modified: 2008-12-21 03:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-29 13:47:59 EST
One or more directories are not included within this
package and/or its sub-packages:

=> collectd-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-apache-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-dns-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-email-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-ipmi-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-mysql-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-nginx-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-rrdtool-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-sensors-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-snmp-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

=> collectd-virt-4.4.4-2.fc10.i386 (rawhide-development-i386)
/usr/lib/collectd

Note: It may suffice to add the dir to the main package, provided
that the sub-packages require the main package.

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Fedora Update System 2008-11-30 09:08:05 EST
collectd-4.5.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.fc10
Comment 2 Fedora Update System 2008-11-30 09:08:13 EST
collectd-4.5.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/collectd-4.5.1-1.fc9
Comment 3 Fedora Update System 2008-12-02 20:15:18 EST
collectd-4.5.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10549
Comment 4 Fedora Update System 2008-12-02 20:28:49 EST
collectd-4.5.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10698
Comment 5 Michael Schwendt 2008-12-07 14:54:40 EST
Seems to be fixed.

[...]

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r fedora -r updates -r updates-testing -n ^collectd
Comment 6 Fedora Update System 2008-12-07 16:36:13 EST
collectd-4.5.1-2.1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.1.fc9
Comment 7 Fedora Update System 2008-12-07 16:36:29 EST
collectd-4.5.1-2.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.1.fc10
Comment 8 Fedora Update System 2008-12-09 06:35:26 EST
collectd-4.5.1-2.1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11042
Comment 9 Fedora Update System 2008-12-09 06:39:05 EST
collectd-4.5.1-2.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11067
Comment 10 Fedora Update System 2008-12-21 03:20:20 EST
collectd-4.5.1-2.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-21 03:45:06 EST
collectd-4.5.1-2.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.