Bug 473668 - Window too large to fit on small device's screen
Window too large to fit on small device's screen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 15:59 EST by Darren Fulton
Modified: 2008-12-02 15:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 16:06:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 552870 None None None Never

  None (edit)
Description Darren Fulton 2008-11-29 15:59:42 EST
Description of problem:
Some application windows, usually configuration menus in various programs included in Fedora 10 are too large to be fully displayed on devices with small screens.  These windows typically do not have vertical scroll bars.  Since the buttons to save, cancel, etc. are typically at the bottom of the window and the window is too tall to display the buttons, such programs are largely unusable.  

Version-Release number of selected component (if applicable):


How reproducible:
Very reproducible.

Steps to Reproduce:
1.  Install Fedora 10 on an OLPC XO or EEEPC 7xx netbook.
2.  Log into GNOME, KDE, or LXDE.
3.  Launch Ekiga, open "Configuration Assistant".  OR, launch Thunderbird, open Account Settings, click "Copies and Folders".  OR, launch KOrganizer, open Configure KOrganizer [window too wide also].  There are many other examples, including the gnome-mouse-properties dialog window.
  
Actual results:
Window too big to be useful.

Expected results:
Window displays at size equal to or less than the usable screen space available on the monitor and all data, options, and features are available.

Additional info:
Comment 1 Peter Robinson 2008-11-30 16:06:53 EST
I actually reported this upstream to ekiga quite a while ago. I've attached the bug report number via the external bug reference.
Comment 2 Darren Fulton 2008-11-30 16:14:59 EST
Thank you.  What shall we do about all of the other applications that have the same issue?  Should we open one ticket per application or should we open one ticket and list all of the offending applications within that ticket?

--
Darren Fulton
Comment 3 Peter Robinson 2008-11-30 16:41:17 EST
A new bug report for every issue. There's only one application that can be assigned per bug,
Comment 4 Peter Robinson 2008-12-02 15:07:38 EST
Darren: There's also bug 287711 for evolution as your interested.

Note You need to log in before you can comment on or make changes to this bug.