Bug 473672 - upgrade f9->f10 with Promise pdc2027x hang
upgrade f9->f10 with Promise pdc2027x hang
Status: CLOSED DUPLICATE of bug 409931
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
10
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 17:16 EST by Levente Farkas
Modified: 2008-12-03 04:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 04:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-11-29 17:16:32 EST
hi,
i try to upgrade from f9->f10 the graphical installer simple hang (which is imho a bug). when i start it in text mode i've got an error that it can't find /dev/mapper/pdc_fbdiccjg and neither retry nor cancel help. so currently on that machine it's not possible to upgrade.
while in the console the error:
-------------------------------------------
ERROR: Activating raid pdc_fbdiccjg failed:
       table: 0 0 linear /dev/mapper/pdc_fbdiccjg
       exception: size must be positive
CRITICAL: parted exception: Error:
       Could not start device /dev/mapper/pdc_fbdiccjg no such file or directory
-------------------------------------------
the machine is an asus p4b533-e motherboard with promise pdc20276 fake raid controller which is disabled in the bios and there is no disk on it, but the kernel still find it. it has 2 pata disk with 2 partition which yield:
- md0 /boot
- md1 lvm vg (inside lv swap and /)
but as anaconda can't find the installed system i'm not able to upgrade (preupgrade failed with the same problem).
Comment 1 Levente Farkas 2008-11-29 17:23:05 EST
a few more info 

about the system:
-------------------------------------------
# cat /proc/partitions 
major minor  #blocks  name

   8     0   78184008 sda
   8     1     104391 sda1
   8     2   78075900 sda2
   8    16   78184008 sdb
   8    17     104391 sdb1
   8    18   78075900 sdb2
   9     1   78075776 md1
 253     0   15335424 dm-0
 253     1    2097152 dm-1
 253     2   60620800 dm-2
   9     0     104320 md0
 253     3   60619772 dm-3
# cat /proc/mdstat 
Personalities : [raid1] [raid6] [raid5] [raid4] 
md0 : active raid1 sda1[0] sdb1[1]
      104320 blocks [2/2] [UU]
      
md1 : active raid1 sda2[0] sdb2[1]
      78075776 blocks [2/2] [UU]
      
unused devices: <none>
# cat /etc/fstab 
/dev/System/root        /                       ext3    defaults        1 1
/dev/md0                /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/System/swap        swap                    swap    defaults        0 0
# cat /etc/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/System/root
#          initrd /initrd-version.img
#boot=/dev/md0
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Upgrade to Fedora 10 (Cambridge)
	kernel /upgrade/vmlinuz preupgrade repo=hd:UUID=a310d15b-4a9b-44a0-a50c-6f025004e0b5:/var/cache/yum/preupgrade stage2=http://sunsite.informatik.rwth-aachen.de/ftp/pub/Linux/fedora/linux/releases/10/Fedora/i386/os/images/install.img ks=hd:UUID=a28359f7-e1e3-8e6c-7cea-f2167df41199:/upgrade/ks.cfg
	initrd /upgrade/initrd.img
title Fedora (2.6.27.5-41.fc9.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.27.5-41.fc9.i686 ro root=/dev/System/root
	initrd /initrd-2.6.27.5-41.fc9.i686.img
title Memtest86+ (2.01)
	root (hd0,0)
	kernel /memtest86+-2.01 ro root=/dev/System/root
Comment 2 Joel Andres Granados 2008-12-02 11:46:56 EST
do you have the log file of your install?
Please look at http://fedoraproject.org/wiki/Anaconda/BugReporting
Comment 3 Levente Farkas 2008-12-02 15:37:34 EST
no i don't just what i wrote down.
-------------------------------------------
ERROR: Activating raid pdc_fbdiccjg failed:
       table: 0 0 linear /dev/mapper/pdc_fbdiccjg
       exception: size must be positive
CRITICAL: parted exception: Error:
       Could not start device /dev/mapper/pdc_fbdiccjg no such file or
directory
-------------------------------------------
anyway i solved the problem give "nodmraid" option to the kernel option at install time.
Comment 4 Joel Andres Granados 2008-12-03 04:11:27 EST

*** This bug has been marked as a duplicate of bug 409931 ***

Note You need to log in before you can comment on or make changes to this bug.