Bug 473674 - missing aot compiled so
missing aot compiled so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 18:15 EST by Mark Wielaard
Modified: 2009-10-27 12:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 12:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2008-11-29 18:15:02 EST
Description of problem:

There is no gcj precompiled shared library and db for org.eclipse.jdt.core_3.4.2.v_883_R34x.jar

Version-Release number of selected component (if applicable):

eclipse-ecj-3.4.1-5.fc10.x86_64
(This was fine with eclipse-ecj-3.3.2-12.fc9.i386)

How reproducible:

Always.

Steps to Reproduce:
1. gij -jar /usr/share/java/ecj.jar <lots-of-java-source-files>

Actual results:

Very slow compilation.

Expected results:

Very fast compilation.

Additional info:

Since ecj is used to bootstrap gcj and icedtea which contain lots and lots of java source files this is causes a very big slowdown.
Comment 1 Andrew Overholt 2008-12-01 08:28:00 EST
We don't build AOT bits for Eclipse packages anymore.
Comment 2 Andrew John Hughes 2008-12-19 13:41:36 EST
Everything must be very slow now then... this move seems insane IMO.
Comment 3 Andrew Overholt 2008-12-19 14:13:53 EST
Nothing is slow if you're not using gcj/gij :)  Seriously, smolt numbers show that we have *very* few users of non-x86/x86_64 who are all getting the benefits of HotSpot.

Regardless, I have a build going in koji now with AOT bits for ecj for the IcedTea folks.
Comment 4 Andrew John Hughes 2008-12-21 21:34:46 EST
ecj is incredibly slow under gij and given you need to build IcedTea and get HotSpot...
Indeed things will be slow under anything on PPC, etc.
What was the reason for pulling this and at such short notice?
Comment 5 Andrew Overholt 2008-12-22 11:09:49 EST
The latest Eclipse build in rawhide has AOT bits.
Comment 7 Andrew John Hughes 2008-12-22 11:29:06 EST
Thanks :)

Note You need to log in before you can comment on or make changes to this bug.