Bug 473680 - decrypt/import/verify broken in nautilus
decrypt/import/verify broken in nautilus
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: seahorse-plugins (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 19:02 EST by Stephan Sachse
Modified: 2009-01-07 04:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Sachse 2008-11-29 19:02:36 EST
Description of problem:

since fc10 there is no more right-click menue for decrypt/import/verify in nautilus only encrypt and sign is there. for decrypt/import/verify you must double-click on the file (it sucks, but so what). this functionality is broken because of a missing update-desktop-database in the postinstall scriptlet. after running update-desktop-database by hand all works fine (but it sucks ;))

Version-Release number of selected component (if applicable):
seahorse-2.24.1-1.fc10.i386
seahorse-plugins-2.24.1-2.fc10.i386

Steps to Reproduce:
1. double-click on a *.pgp file
  
Actual results:
error message about no application available to open this file

Expected results:
decrypt the file
Comment 1 Fedora Update System 2008-12-12 18:14:05 EST
seahorse-plugins-2.24.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/seahorse-plugins-2.24.1-3.fc10
Comment 2 Stephan Sachse 2008-12-12 18:34:00 EST
worms for me

but seahorse-daemon still crashs after verify a .sig

out from terminal

** Message: init gpgme version 1.1.7

** (seahorse-daemon:20395): WARNING **: key 'openpgp:C9A34A200B84DA8FE72B17EAC01E44A683002C2E' in key text does not exist
7626cba5-eb5c-b737-4cef08fe-598599be is dumped

seahorse-daemon crashs if the notification window is closes (click or timeout)
Comment 3 Fedora Update System 2008-12-17 19:31:28 EST
seahorse-plugins-2.24.1-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update seahorse-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11294
Comment 4 Fedora Update System 2009-01-07 04:21:47 EST
seahorse-plugins-2.24.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.