Bug 473738 - Source rpm of zsh-4.3.4-8.fc10 does not compile
Source rpm of zsh-4.3.4-8.fc10 does not compile
Status: CLOSED DUPLICATE of bug 465069
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 00:12 EST by Nathan G. Grennan
Modified: 2008-12-20 14:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-20 14:27:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2008-11-30 00:12:33 EST
Description of problem:
Source rpm does not compile on Fedora 10. The rpm-build package now has "%_default_patch_fuzz    0", where as zsh-4.3.4-8 requires fuzz 1 for part of the zsh-serial patch.

Version-Release number of selected component (if applicable):
zsh-4.3.4-8.fc10.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Install Fedora 10
2. Install zsh-4.3.4-8.fc10 src rpm
3. rpmbuild -bb zsh.spec
  
Actual results:
+ echo 'Patch #0 (zsh-serial.patch):'
Patch #0 (zsh-serial.patch):
+ /bin/cat /home/builder/rpmbuild/SOURCES/zsh-4.3.4/zsh-serial.patch
+ /usr/bin/patch -s -p1 -b --suffix .serial --fuzz=0
1 out of 3 hunks FAILED -- saving rejects to file Src/init.c.rej
error: Bad exit status from /home/builder/rpmbuild/TMP/rpm-tmp.qiNgym (%prep)

Expected results:
Patch #0 (zsh-serial.patch):
+ /bin/cat /home/builder/rpmbuild/SOURCES/zsh-4.3.4/zsh-serial.patch
+ /usr/bin/patch -s -p1 -b --suffix .serial --fuzz=0


Additional info:
Comment 1 James Antill 2008-12-20 14:27:49 EST

*** This bug has been marked as a duplicate of bug 465069 ***

Note You need to log in before you can comment on or make changes to this bug.