Bug 473751 - Anaconda force / partition to be ext3 instead of ext2
Anaconda force / partition to be ext3 instead of ext2
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 03:37 EST by am
Modified: 2008-12-01 11:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 11:59:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description am 2008-11-30 03:37:09 EST
Description of problem:
When installing F10 on a fresh new computer using a livecd, automatic partitioning creates the following partitions :
- /boot, in ext3
- LVM

LVM contains :
- swap
- /, ext3

Although I change type of / to ext2, it is ignored: after installing, I can see / is a ext3 partition.

How reproducible: Always

Steps to Reproduce:
1. Change /boot and / partition types to ext2
2. Install Fedora from LiveCD
3. Run newly installed Fedora
  
Actual results:
/boot is changed to ext2, but / is not.

Expected results:
/boot and / are changed to ext2.


Additional info:
Computer is an Acer Aspire One with 8Go SSD disk. On these disks, using ext3 is not a good idea, so ext2 is prefered.

Problem occurs with KDE and GNOME F10 livecd. Cannot try with DVD version.

Same problem occurs when using two primary partitions, without LVM.
Comment 1 Jeremy Katz 2008-12-01 11:59:53 EST
This is because with the live install, we're copying over the image from the live images which is an ext3 image.  There's really not anything that we can do with the way we do installs

Note You need to log in before you can comment on or make changes to this bug.