Bug 473753 - xterm with black screen for TrueType fonts
xterm with black screen for TrueType fonts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 04:22 EST by Marco Guazzone
Modified: 2009-03-09 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 242-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marco Guazzone 2008-11-30 04:22:50 EST
Description of problem:

If xterm is configured to use TrueType fonts (both through "-fa" command line options and via ".Xresources" file), when it is started it shows a window with a black screen (neither background or foreground is visible).
For restoring the screen you have to issue a command which produces some output, like "ls". After issuing this command you can see the "normal" xterm window with the chosen font.
The problem does not occur if TrueType fonts are not used.

Moreover, when xterm is start (both when using TrueType fonts and when not), the command produces a warning:

 Warning: Cannot convert string "nil2" to type FontStruct

Looking for this message with Google, it seems this might be solved by installing the package xorg-x11-fonts-misc (containing bitmap fonts).
I haven't tried yet.


Version-Release number of selected component (if applicable):

237-1.fc10


How reproducible:


Steps to Reproduce:
1. Open a terminal
2. From the terminal prompt, run the command: xterm
3. From the terminal prompt, run the command: xterm -fa "monospace"
   (you can try with other fonts like "times", "Courier New". You can also include the option -cjk_width -- found on the xterm man page)

  
Actual results:

From step 2, you get an xterm window without any problem
From step 3, you get an xterm window completely black (but window decorations)


Expected results:

From step 3, you should immediately get an xterm window without the black screen and with the chosen font.

Additional info:
Comment 1 Miroslav Lichvar 2008-12-02 04:24:18 EST
Installing the xorg-x11-fonts-misc fixes the problem for me.

CCing upstream maintainer.
Comment 2 Marco Guazzone 2008-12-02 07:55:46 EST
Just tried to install this package.
The problem is fixed for me too (both the black screen and the warning message).

This package should be included in the dependencies list of the xterm rpms.

In fact, its installation not only solves the black screen problem (caused by the use of TrueType fonts) but makes further disappear the warning message (issued even if TrueType fonts are not used).
Comment 3 Miroslav Lichvar 2009-01-27 06:39:17 EST
It looks like this bug was fixed in upstream patch #241. I'll prepare an update.
Comment 4 Fedora Update System 2009-03-02 08:12:43 EST
xterm-242-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xterm-242-2.fc10
Comment 5 Fedora Update System 2009-03-02 08:12:48 EST
xterm-242-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xterm-242-2.fc9
Comment 6 Fedora Update System 2009-03-02 12:02:56 EST
xterm-242-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xterm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2239
Comment 7 Fedora Update System 2009-03-09 18:45:42 EDT
xterm-242-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-03-09 19:00:48 EDT
xterm-242-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.