Bug 473780 - Add gcc and kernel-headers requires to the spec file
Add gcc and kernel-headers requires to the spec file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dkms (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 10:18 EST by Rehan Khan
Modified: 2008-12-07 13:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 12:34:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehan Khan 2008-11-30 10:18:32 EST
Description of problem:
If a user is installing dkms the dkms package should probably specify gcc and kernel-headers in addition to kernel-devel as a basic minimum so that installing dkms will install the absolute minimum required to build most dkms packages.

Version-Release number of selected component (if applicable):
N/A

How reproducible:

N/A

Steps to Reproduce:
1. yum install dkms (on a clean install of Fedora) 
2. install a dkms based third party module, reboot
3. dkms fails due to missing dependancies (headers and compiler)
  
Actual results:
N/A

Expected results:
yum install dkms installs any additional packages that are usually needed by a dkms based driver.

Additional info:
Comment 1 Matt Domsch 2008-11-30 12:34:13 EST
This is in fact expected behavior, and DKMS itself throws runtime errors when no compiler or matching kernel headers are present yet it has been asked to rebuild a module.

For many users, particularly those in data centers, policy dictates they not have compilers or kernel-devel installed on their systems.  DKMS itself only needs compiler and kernel-devel if 'dkms build' is invoked.  For all other DKMS functionality, these aren't needed.  In a very typical case of pre-compiled modules distributed in a DKMSified RPM, the compiler and kernel-devel packages are not needed.
Comment 2 Rehan Khan 2008-12-07 13:06:44 EST
Ok, thanks. I didn't know dkms could be used for binary only installs, will review the documentation again. OTOH it would be more user friendly perhaps if DKMS in fedora was more straight forward, either by adding a note to the description field of the spec file saying that if a user wants to be able to compile drivers (or continuously update thier drivers for each new kernel) then they will need gcc and kernel headers/devel at a minimum or to do something similar to the mandriva rpm where there is a minimal and full package or perhaps dkms and dkms-full or something.

cheers

Note You need to log in before you can comment on or make changes to this bug.