Bug 473786 - SELinux prevents KDE media players from working properly
SELinux prevents KDE media players from working properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 473783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 10:54 EST by Marcelo
Modified: 2008-12-02 10:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 10:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The requested audit.log file (2.16 MB, application/octet-stream)
2008-12-01 17:37 EST, Marcelo
no flags Details

  None (edit)
Description Marcelo 2008-11-30 10:54:20 EST
Description of problem:
When SELinux is in enforce mode, Kaffeine and Dragon Player are not able to play divx nor flv videos. Audio is heard, but no image is shown.
Also, both of them and also kplayer, mplayer and other media players become unstable when reproducing any kind of video, choking when playing, freezing and crashing often.
Problem is solved when SELinux is disabled.


How reproducible:
Always

Steps to Reproduce:
1. Set SELinux to enforce mode
2. Install above mentioned applications and required codecs
3. Try to play divx and flv videos
  
Actual results:
Only audio is played, no images. Other kinds of video are played, but the media players become unstable. MPlayer and KPlayer work, but are unstable as well


Expected results:
Videos should be correctly played by media players.
Comment 1 Daniel Walsh 2008-12-01 17:06:47 EST
Please attach the avc messages from /var/log/audit/audit.log
Comment 2 Marcelo 2008-12-01 17:37:33 EST
Created attachment 325309 [details]
The requested audit.log file

attached the requested file.
Very big file, the events in there do not show the dates when they were generated. Don't know what in there would be useful for you to trace the problem, so I attached the entire file.
Comment 3 Daniel Walsh 2008-12-02 10:50:20 EST
Looks like you have a badly labeled system, or  your homedir does not contain labels.

touch /.autorelabel; reboot
Comment 4 Daniel Walsh 2008-12-02 10:50:53 EST
*** Bug 473783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.