This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 473793 - After using preupgrade for f9->f10, fedora.repo should not be updated?
After using preupgrade for f9->f10, fedora.repo should not be updated?
Status: CLOSED DUPLICATE of bug 471579
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 11:38 EST by András Szilárd
Modified: 2014-01-21 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 16:12:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description András Szilárd 2008-11-30 11:38:52 EST
Description of problem:
After (yum update, yum install preupgrade,) preupgrade the /etc/yum.repos.d/fedora.repo was not updated to the Fedora 10 repository. Only "Fedora 10 - x86_64 - Updates" was available. Should not that repo file be updated?

The "original" problem can be seen here: https://bugzilla.rpmfusion.org/show_bug.cgi?id=207

Version-Release number of selected component (if applicable):
$ rpm -qa preupgrade
preupgrade-1.0.0-1.fc10.noarch

How reproducible:
Did not try.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
F10 repository should be added after preupgrade?

Additional info:
I could not really find what the Fedora 10 repo supposed to be.
Smart Package Manager gave me some hints, but it did not updated the repo file, even though I accepted the proposed changes. Finally, I updated the fedora.repo file manually.
Comment 1 Will Woods 2008-12-05 14:12:31 EST
Do you have a file named /etc/yum.repos.d/fedora.repo.rpmnew?

If you customized/modified your fedora.repo, the upgrade will leave it alone. If that file exists, copy it over /etc/yum.repos.d/fedora.repo and everything should be OK.

(See bug 471579)
Comment 2 András Szilárd 2008-12-05 16:05:28 EST
Yes, I have modified the repo file (in July), and the repo.rpmnew file seems to be fine. The new repo file does not contain the exact release and arch, but parameters. So, I guess, this will not be an issue anymore.
Thanks, and let me know if you want to check anything else.
Comment 3 Will Woods 2008-12-05 16:12:32 EST

*** This bug has been marked as a duplicate of bug 471579 ***

Note You need to log in before you can comment on or make changes to this bug.