Bug 473804 - rt2500pci doesn't get an IP via DHCP
rt2500pci doesn't get an IP via DHCP
Status: CLOSED DUPLICATE of bug 457441
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 14:06 EST by Jan Willies
Modified: 2009-07-26 06:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 12:37:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Willies 2008-11-30 14:06:13 EST
Description of problem: My rt2500pci card doesn't get an IP via DHCP. It authenticates fine with the AP (via WPA2) but dhclient times out. Setting the IP manually via NM works fine.

Nov 30 20:01:53 elke NetworkManager: <info>  (wlan0): supplicant connection state:  associating -> associated
Nov 30 20:01:53 elke NetworkManager: <info>  (wlan0): supplicant connection state:  associated -> 4-way handshake
Nov 30 20:01:53 elke NetworkManager: <info>  (wlan0): supplicant connection state:  4-way handshake -> group handshake
Nov 30 20:01:53 elke NetworkManager: <info>  (wlan0): supplicant connection state:  group handshake -> completed
Nov 30 20:01:53 elke NetworkManager: <info>  Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'schnauze'.
Nov 30 20:01:53 elke NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Nov 30 20:01:53 elke NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Nov 30 20:01:53 elke NetworkManager: <info>  (wlan0): device state change: 5 -> 7
Nov 30 20:01:53 elke NetworkManager: <info>  Activation (wlan0) Beginning DHCP transaction.
Nov 30 20:01:53 elke dhclient: Internet Systems Consortium DHCP Client 4.0.0
Nov 30 20:01:53 elke dhclient: Copyright 2004-2007 Internet Systems Consortium.
Nov 30 20:01:53 elke dhclient: All rights reserved.
Nov 30 20:01:53 elke dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Nov 30 20:01:53 elke dhclient: 
Nov 30 20:01:53 elke NetworkManager: <info>  dhclient started with pid 4320
Nov 30 20:01:53 elke NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Nov 30 20:01:53 elke NetworkManager: <info>  DHCP: device wlan0 state changed normal exit -> preinit
Nov 30 20:01:53 elke dhclient: Listening on LPF/wlan0/00:11:09:be:de:4f
Nov 30 20:01:53 elke dhclient: Sending on   LPF/wlan0/00:11:09:be:de:4f
Nov 30 20:01:53 elke dhclient: Sending on   Socket/fallback
Nov 30 20:01:53 elke ntpd[1884]: Deleting interface #7 wlan0, 192.168.2.206#123, interface stats: received=3, sent=3, dropped=0, active_time=87 secs
Nov 30 20:01:57 elke dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
Nov 30 20:02:01 elke dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
Nov 30 20:02:08 elke dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
Nov 30 20:02:16 elke dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
Nov 30 20:02:27 elke dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
Nov 30 20:02:38 elke NetworkManager: <info>  Device 'wlan0' DHCP transaction took too long (>45s), stopping it.
Nov 30 20:02:38 elke NetworkManager: <info>  wlan0: canceled DHCP transaction, dhcp client pid 4320
Nov 30 20:02:38 elke NetworkManager: <info>  Activation (wlan0) Stage 4 of 5 (IP Configure Timeout) scheduled...
Nov 30 20:02:38 elke NetworkManager: <info>  Activation (wlan0) Stage 4 of 5 (IP Configure Timeout) started...
Nov 30 20:02:38 elke NetworkManager: <info>  (wlan0): device state change: 7 -> 9
Nov 30 20:02:38 elke NetworkManager: <info>  Activation (wlan0) failed for access point (schnauze)
Nov 30 20:02:38 elke NetworkManager: <info>  Marking connection 'Auto schnauze' invalid.
Nov 30 20:02:38 elke NetworkManager: <info>  Activation (wlan0) failed.
Nov 30 20:02:38 elke NetworkManager: <info>  Activation (wlan0) Stage 4 of 5 (IP Configure Timeout) complete.
Nov 30 20:02:38 elke NetworkManager: <info>  (wlan0): device state change: 9 -> 3
Nov 30 20:02:38 elke NetworkManager: <info>  (wlan0): deactivating device (reason: 0).
Nov 30 20:02:38 elke NetworkManager: <info>  Policy set 'System eth0' (eth0) as default for routing and DNS.


Version-Release number of selected component (if applicable): NM in Fedora 10


How reproducible: always


Steps to Reproduce:
1. connect to a Network with rt2500pci
2. wait
3. see how it doesn't get an IP
  
Actual results: dhclient running into a timeout


Expected results: get the DHCP infos

Additional info: my other laptop gets the IP just fine
Comment 1 Jan Willies 2008-12-14 12:37:42 EST

*** This bug has been marked as a duplicate of bug 457441 ***

Note You need to log in before you can comment on or make changes to this bug.