Bug 473805 - Mounting local filesystems: mount: unknown filesystem type 'fuseblk'
Mounting local filesystems: mount: unknown filesystem type 'fuseblk'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 14:13 EST by Edward Kuns
Modified: 2008-12-02 23:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:17:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 2008-11-30 14:13:53 EST
Upgraded Fedora 8 to Fedora 10.  I'd previously had my NTFS partition in /etc/fstab as:

/dev/sda3 /winders ntfs-3g noauto,user,dmask=022,fmask=133,locale=en_US.UTF-8,ro 0 0

but Fedora 10 seemed to discover my windows partition and wanted to mount it under /media.  (After I used System -> Administration -> NTFS Configuration Tool)  However, upon rebooting, I got the complaint in the summary:

Mounting local filesystems:  mount: unknown filesystem type 'fuseblk'

which I see in /var/log/boot.log as well as during bootup.  Later in the boot log I see:

Loading fuse module.
Mounting fuse control filesystem.
Mounting other filesystems:  mount: wrong fs type, bad option, bad superblock on /dev/sda3,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

I have the following relevent versions of software installed:

ntfs-3g-1.5012-4.fc10.i386
fuse-2.7.4-1.fc10.i386
util-linux-ng-2.14.1-3.1.fc10.i386

After the full bootup and logging in, my windows partition is not mounted.
Comment 1 Tom "spot" Callaway 2008-11-30 17:56:33 EST
Hmm, thats odd. A few questions:

1. Are you sure /dev/sda3 is still your NTFS partition? Double-check with parted or fdisk.
2. Does a manual mount work? (e.g. mount -t ntfs-3g -o noauto,user,dmask=022,fmask=133,locale=en_US.UTF-8,ro /dev/sda3 /winders )
3. Double-check what is currently in /etc/fstab, the "noauto" option should prevent it from being mounted at "Mounting local filesystems".

As to the "Mounting other filesystems:" prompt during init... I'm not sure where that message is coming from. The fuse init script doesn't have that text string, nor does /etc/rc.d/rc.sysinit...

Automounting of internal NTFS partitions into /media is expected (that got enabled in Fedora 9), but putting it into /etc/fstab should also work.
Comment 2 Edward Kuns 2008-11-30 18:15:34 EST
[root@delius ekuns]# fdisk -l /dev/sda

Disk /dev/sda: 320.0 GB, 320072933376 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           7       56196   de  Dell Utility
/dev/sda2               8         400     3156772+  83  Linux
/dev/sda3   *         401        6927    52428127+   7  HPFS/NTFS
/dev/sda4            6928       38913   256927545    f  W95 Ext'd (LBA)
/dev/sda5            6928        8493    12578863+  83  Linux
/dev/sda6            8494       12670    33551721   83  Linux
/dev/sda7           12671       12866     1574338+  82  Linux swap / Solaris
/dev/sda8           12867       38913   209222496    b  W95 FAT32

[root@delius ekuns]# fsck -t ntfs-3g /dev/sda3
fsck 1.41.3 (12-Oct-2008)
fsck: fsck.fuseblk: not found
fsck: Error 2 while executing fsck.fuseblk for /dev/sda3

I wonder if my NTFS partition has gotten corrupted.  I have not enabled write support and I have not made any changes from Linux.  I'll have to reboot into Windows (which I don't do often) and see if it's OK from Windows.
Comment 3 Edward Kuns 2008-12-01 00:44:42 EST
I booted into Windows and ran chkdsk on the C: drive, which of course never fully completed.  I did a defrag under Windows, which completed.  Under Linux, to check the partition, I did:

[root@delius ekuns]# ntfsresize -fi /dev/sda3
ntfsresize v2.0.0 (libntfs 10:0:0)
Device name        : /dev/sda3
NTFS volume version: 3.1
Cluster size       : 4096 bytes
Current volume size: 53686399488 bytes (53687 MB)
Current device size: 53686402560 bytes (53687 MB)
Checking filesystem consistency ...
100.00 percent completed
Accounting clusters ...
Space in use       : 14884 MB (27.7%)
Collecting resizing constraints ...
You might resize at 14883459072 bytes or 14884 MB (freeing 38803 MB).
Please make a test run using both the -n and -s options before real resizing!

Looking in /var/log/boot.log, I still see:

Remounting root filesystem in read-write mode:   OK
Mounting local filesystems:  mount: unknown filesystem type 'fuseblk'  FAILED
Enabling local filesystem quotas:    OK

and then later on

Loading fuse module.
Mounting fuse control filesystem.
Mounting other filesystems:  mount: wrong fs type, bad option, bad superblock on /dev/sda3,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

FAILED

In /var/log/messages, I see

Nov 30 23:17:26 delius kernel: fuse init (API version 7.9)
Nov 30 23:17:26 delius kernel: type=1400 audit(1228108645.722:7): avc:  denied  { write } for  pid=2299 comm="mount" path="/0" dev=devpts ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:devpts_t:s0 tclass=chr_file

Note that I have selinux in permissive mode on this laptop.  I do see more than one avc for mount during bootup, but my understanding is that permissive will complain but will not actually prevent anything.

# getenforce 
Permissive
Comment 4 Edward Kuns 2008-12-01 00:49:54 EST
Also, once I used the NTFS config tool to configure this, I took it out of /etc/fstab.  In /etc/fstab I had the drive mounted as /winders (I know, I crack me up) but the newer config tool wanted to mount it under /media, so I just commented out the fstab mount.  I don't know where the new configuration is kept.  But now if I bring up the NTFS Configuration Tool, it knows about /dev/sda3 and that it should be mounted under /media, but it can no longer show the % used on this partition.

It's as if something is now wrong with this partition, but between when this worked and when this stopped working, I never mounted the partition writable under Linux and I never booted into Windows.  Thus, there should have been absolutely no changes to this partition.

And tonight when I did boot into Windows to check things out, Windows had no complaints about the C: drive.
Comment 5 Tom "spot" Callaway 2008-12-01 10:51:18 EST
Does the manual mount command work? It seems as if somehow the filesystem type for ntfs-3g has gotten confused with fuseblk...

I'm not familiar with the "NTFS Configuration Tool" (its about the only piece of the Fedora NTFS stack I don't maintain), so I'm starting to get suspicious about it.

Can you attach a copy of your /etc/fstab?

Also, please paste the output from:

grep fuse /proc/filesystems

I think something odd is happening in the fstab.
Comment 6 Edward Kuns 2008-12-01 20:34:07 EST
If I put my fstab entry back (by uncommenting it) and I manually mount it, it works and I get the following entries in /var/log/messages:

Dec  1 19:27:46 delius ntfs-3g[18331]: Version 1.5012 integrated FUSE 27
Dec  1 19:27:46 delius ntfs-3g[18331]: Mounted /dev/sda3 (Read-Only, label "", NTFS 3.1)
Dec  1 19:27:46 delius ntfs-3g[18331]: Cmdline options: ro,noexec,nosuid,nodev,noauto,user,dmask=022,fmask=133,locale=en_US.UTF-8
Dec  1 19:27:46 delius ntfs-3g[18331]: Mount options: ro,noexec,nosuid,nodev,user,silent,allow_other,nonempty,default_permissions,relatime,fsname=/dev/sda3,blkdev,blksize=4096

My fstab entry is:

/dev/sda3	/winders	ntfs-3g	noauto,user,dmask=022,fmask=133,locale=en_US.UTF-8,ro	0	0

Ah, you got me looking in the right place.  I didn't notice this two-line entry, automatically added to fstab I suppose by the GUI NTFS Configuration Tool utility:

#Entry for /dev/sda3 :
UUID=0A18365B183645CB /media/winders fuseblk defaults,allow_other,blksize=4096 0 0

That tool is putting the wrong file system there, it looks like.  I'll correct this entry and reboot and see if that fixes things....
Comment 7 Edward Kuns 2008-12-01 22:00:08 EST
Changing "fuseblk" to "ntfs-3g" in fstab in the automatically-generated entry solved the problem.  Now the partition is mounted at boot time and when I view it in the GUI NTFS Configuration Tool utility, it looks correct and I see the usage of the partition.

Now I need to look at the options used because this GUI utility does not have any interface to modify the options it inserts into the fstab.

One of the annoyances of the programmatic editing of the fstab used here (and by anaconda) is that all formatting I may have applied in the file is all discarded and things are inserted into the middle.  Empty lines (aka whitespace) are removed.  This means sometimes something can be added into the middle and I won't notice.  :(  If I had looked more carefully, I probably would have seen the problem much earlier.

(Aside:  At least my NFS mount entries weren't discarded by the NTFS GUI config utility as they always are when I upgrade!  And at least this time during the upgrade, Anaconda made a backup of my original fstab before it discarded half of my entries!)

Anyway, your intuition was correct.  It's /usr/bin/ntfs-config from ntfs-config-1.0.1-2.fc10.noarch that caused this problem.
Comment 8 Tom "spot" Callaway 2008-12-02 11:17:43 EST
Glad that you got this sorted out. I'd recommend that you file a bug against ntfs-config, that fuseblk line is totally incorrect.
Comment 9 Edward Kuns 2008-12-02 23:53:38 EST
Done.  Bug 474282.

Note You need to log in before you can comment on or make changes to this bug.