Bug 473815 - font/screen corruption with radeon/EXA when firefox is launched
font/screen corruption with radeon/EXA when firefox is launched
Status: CLOSED DUPLICATE of bug 473895
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 16:38 EST by Hin-Tak Leung
Modified: 2008-12-01 22:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 22:26:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one screen shot showing corruption (64.10 KB, image/png)
2008-11-30 16:38 EST, Hin-Tak Leung
no flags Details
another screenshot (27.66 KB, image/png)
2008-11-30 16:40 EST, Hin-Tak Leung
no flags Details
Xorg.0.log, no xorg.conf (64.76 KB, text/plain)
2008-11-30 16:42 EST, Hin-Tak Leung
no flags Details

  None (edit)
Description Hin-Tak Leung 2008-11-30 16:38:22 EST
Created attachment 325147 [details]
one screen shot showing corruption

Description of problem:
screen and fotn is corrupted a little after firefox is started restoring
some old session.

Version-Release number of selected component (if applicable):
some taken from koji:
kernel-2.6.27.7-132.fc10 
xorg-x11-drv-ati-6.9.0-60.fc10
xorg-x11-server-Xorg-1.5.3-5.fc10 

How reproducible:
always

Steps to Reproduce:
1. boot without any xorg.conf
2. start firefox
3. watch screen
  
Actual results:
corrupted display after a few web pages from old session is restored.

Expected results:
normal usage.

Additional info:
will attach screenshot (screen capture seems to be able to capture the corruption), and Xorg.0.log. It was run without xorg.conf, so there is no xorg.conf to attach.
Comment 1 Hin-Tak Leung 2008-11-30 16:40:09 EST
Created attachment 325148 [details]
another screenshot

here is another one.
Comment 2 Hin-Tak Leung 2008-11-30 16:42:28 EST
Created attachment 325149 [details]
Xorg.0.log, no xorg.conf

Xorg.0.log, without xorg.conf.

The hardware is (should be somewhere in the log, just saving somebody looking it up):

VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
Comment 3 Hin-Tak Leung 2008-11-30 17:08:21 EST
Recently the nomodeset situation seems to have changed, so I tried various combinations. There is no winners, and each of them all have their own problems:

radeon + EXA: tearing while scrolling, and most recently, font/screen corruption when firefox is used. (bug 473815)

radeon + XAA: need to boot with nomodeset, or it goes into a black screen instead of GDM. (bug 464896 ?)

radeonhd : no xvideo (bug 473819)

For general use, radeon + XAA is the best at the moment. 
(RS690M [Radeon X1200 Series])
Comment 4 Matěj Cepl 2008-12-01 10:16:00 EST
Is it problem just with Firefox or other X applications show garbage instead of characters as well? What's your locale?
Comment 5 Hin-Tak Leung 2008-12-01 11:55:27 EST
It is the whole desktop going funny color (plus fonts garbage) - if it wasn't already 24-bit/true-color display I would say it looks like the good old days with 8-bit display, when the palette has gone wrong. 

$ export | grep LANG
declare -x GDM_LANG="en_GB.utf8"
declare -x LANG="en_GB.utf8"
Comment 6 Hin-Tak Leung 2008-12-01 22:26:46 EST
Seems to be the same as 473895 .

*** This bug has been marked as a duplicate of bug 473895 ***

Note You need to log in before you can comment on or make changes to this bug.