This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 473827 - NetworkManager-gnome and knetworkmanager both installed, under KDE
NetworkManager-gnome and knetworkmanager both installed, under KDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 17:59 EST by Stefan Neufeind
Modified: 2009-10-16 18:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 15:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-11-30 17:59:04 EST
Installed both applets (for gnome and knetworkmanager) to be prepared for both environments. However when login in under KDE I now get two icons in the systray (one being the gnome-applet, the other being the kde-variant). Since they both use the same NetworkManager-backend that works without bigger problems, but there are detail-problems like e.g. the gnome-applet not being able to access the KDE-keyring anymore (for wireless-passwords etc.).
Comment 1 Arkezis 2009-01-22 15:34:38 EST
More, when I remove KDE group, I have removed NetworkManager-gnome !
Comment 2 Stefan Neufeind 2009-02-09 16:35:41 EST
Easy solution to not start nm-applet when running KDE ...

/etc/xdg/autostart/nm-applet.desktop and add:
NotShowIn=KDE

Might that be a solution to ship in NetworkManager-gnome?
Comment 6 Dan Williams 2009-10-15 00:09:40 EDT
We don't ship OnlyShowIn=Gnome because the applet actually can be used in KDE (as long as gnome-keyring is also installed) and in fact we did that for a while before KDE ported their applet to NM 0.7.x.  Is this still an issue?  If it is, we should probably redirect the bug to the releng to adjust comps now that KDE4 has fine 0.7.x support.
Comment 7 Stefan Neufeind 2009-10-15 03:45:57 EDT
imho we should introduce OnlyShowIn=Gnome for the gnome-part since KDE4 meanwhile has a native KDE4 knetworkmanager again and the network-management-plasmoid is actively being worked on.
Comment 8 Justin Payne 2009-10-15 08:21:41 EDT
You guys do it like you want to, but the KDE plasmoid still has issues. I still use the nm-applet for Gnome.
Comment 9 Dan Williams 2009-10-16 15:31:45 EDT
NetworkManager-gnome just shouldn't be in the comps group for KDE spins.  If you don't specifically add it to comps for your spin, it wont' get in.  But if it's installed, it's expected to be running for the most part since it's XDG session activated.

I really dont' think there's anything we need to do here in NM, because this is a spin installation problem.  If the package is specifically installed, then the functionality should be available.

I assume the KDE spins include the right plasmoid widgets by default and thus KDE users are set up for this.
Comment 10 Stefan Neufeind 2009-10-16 18:31:19 EDT
Well, you are true under the assumption that only KDE _or_ Gnome are installed. But on a desktop you might have users that prefer either of both. And for the KDE-people the gnome-applet is (at least was last time I checked) automatically loaded. And loading it under Gnome only is what "OnlyShowIn=Gnome" would help in that case ...

Note You need to log in before you can comment on or make changes to this bug.