Bug 473836 - Fonts in GNOME look blurry (was: "in Firefox")
Fonts in GNOME look blurry (was: "in Firefox")
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 19:24 EST by An. N
Modified: 2009-03-24 18:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 18:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Blurry fonts in firefox3 (113.25 KB, image/png)
2008-11-30 19:24 EST, An. N
no flags Details
xorg.conf (1.59 KB, text/plain)
2008-12-05 18:34 EST, An. N
no flags Details
Xorg.0.log (12.12 KB, text/plain)
2008-12-05 18:34 EST, An. N
no flags Details
screenshot fonts (31.94 KB, image/png)
2008-12-05 18:38 EST, An. N
no flags Details
FF Preferences (3.80 KB, text/plain)
2008-12-05 18:39 EST, An. N
no flags Details
blurry fonts in oowriter - notice the shaded I, or shades inside the H (1.33 MB, image/png)
2008-12-09 18:01 EST, An. N
no flags Details
blurry fonts in gedit (26.88 KB, image/png)
2008-12-09 18:02 EST, An. N
no flags Details
blurry fonts in seamonkey (202.46 KB, image/png)
2008-12-09 18:04 EST, An. N
no flags Details

  None (edit)
Description An. N 2008-11-30 19:24:01 EST
Created attachment 325162 [details]
Blurry fonts in firefox3

Description of problem:
Fonts in firefox 3 look blurry. The same settings on an older fedora w/ Firefox 1.5 yielded good results.

Subpixel smoothing is enabled in the settings, default fonts remain set (i.e. webpage chooses).

This problem does not exist with fonts in the system (menus, windows, etc - everything is ok).

Version-Release number of selected component (if applicable):
FC10 default

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2. Go to google.com, start a search
3.
  
Actual results:
Fonts look blurry and are antialiased incorrectly

Expected results:
Fonts are antialiased correctly

Additional info:
Image attached - example 'd' is blown up to show the problem up close
Comment 1 Matěj Cepl 2008-12-05 09:37:11 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could we get also attached ~/.mozilla/firefox/*.default/prefs.js file and a screenshot of Edit/Preferences/Content/Extended Font Preferences, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 An. N 2008-12-05 18:34:24 EST
Created attachment 325931 [details]
xorg.conf
Comment 3 An. N 2008-12-05 18:34:47 EST
Created attachment 325932 [details]
Xorg.0.log
Comment 4 An. N 2008-12-05 18:38:33 EST
Created attachment 325934 [details]
screenshot fonts
Comment 5 An. N 2008-12-05 18:39:44 EST
Created attachment 325936 [details]
FF Preferences
Comment 6 Matěj Cepl 2008-12-06 12:04:17 EST
Frankly, I am at loss with this bug -- I don't see anything that bad with attachment 325934 [details], nothing bad in logs, and your settings look totally standard. 

Could I get output of the command

gconftool-2 -R /desktop/gnome/font_rendering

please, to see how the rest of your desktop looks like?

BTW, your desktop is Gnome, right? or something else, like KDE, LXDE, XFCE?
Comment 7 An. N 2008-12-06 17:18:58 EST
Here's the file you requested:
 rgba_order = vrgb
 antialiasing = rgba
 dpi = 86
 hinting = full

Yes, I use GNOME desktop. After a more careful examination it seems to me that the blurring also occurs in openoffice so it might be a more general issue, not Firefox specific (but that's where it's most visible). It's most visible with bold fonts.

My resolution is 1280x1024 @ 19"
Comment 8 Matěj Cepl 2008-12-06 17:47:58 EST
Then this is misconfiguration. Try to play with gnome-appearance-properties to get what you want.

Closing as NOTABUG.
Comment 9 An. N 2008-12-06 20:17:12 EST
This is NOT misconfiguration - this is a clean system install which renders fonts in a way which makes them very difficult to read (firefox, for example, is barely usable!)

I have "played around" with the settings earlier and it did not solve the problem. This is as good as it gets. I had similar settings in other versions of Fedora on the same machine and everything was fine (most recent: FC7).

I do not see how this is "not a bug", if there is nothing that I can do to fix it.
Comment 10 Matěj Cepl 2008-12-07 05:05:50 EST
Sorry, you are complaining that fonts are blurry (i.e., you have anti-aliasing set on too high) and then you have anti-aliasing set on maximum. So, setting anti-aliasing on lower levels would probably fix your problem.
Comment 11 An. N 2008-12-07 18:30:25 EST
1. The antialiasing settings which I have have worked perfectly well with other Fedora versions for as long as I can remember, with the same hardware I own now.

2. I have tried other settings with no luck. Lower antialiasing levels or different pixel orders result in edgy fonts or colored pixel artifacts on font edges.

3. Antialiasing is not correct, as can be seen on the screenshot. It is not too strong, the fonts are just rendered incorrectly, with pixels placed where they should never have been.

I acknowledge that this is not necessarily a problem unique to Firefox but I still believe this is some kind of a bug. I will be happy to re-file it under a more general component.

Thank you, however, for your support.
Comment 12 Matěj Cepl 2008-12-08 12:22:47 EST
(In reply to comment #11)
> I acknowledge that this is not necessarily a problem unique to Firefox but I
> still believe this is some kind of a bug. I will be happy to re-file it under a
> more general component.

OK, as you wish.

Matěj
Comment 13 Orion Poplawski 2008-12-08 12:29:47 EST
Why is this a freefont problem?  Lack of a better font component to file against?
Comment 14 Nicolas Mailhot 2008-12-08 12:52:24 EST
Probably better filed upstream @mozilla

IIRC they had some problem passing rendering options to cairo.

And anyway till Firefox learns to read the desktop font options from XSettings, it'll continue to behave differently from other apps.
Comment 15 Martin Stransky 2008-12-09 02:58:38 EST
Please try to reproduce that bug with official mozilla binary (the latest 3.1 beta 2 is the best candidate) and if the bug is there too we can consider to file it upstream. Firefox really suffers from some font misconfiguration. Anyway, can you check other web browser for the bug? Like seamonkey from F10, it can help us to direct investigation.
Comment 16 Martin Stransky 2008-12-09 02:59:24 EST
Get your beta here - http://www.mozilla.com/en-US/firefox/all-beta.html
Comment 17 An. N 2008-12-09 18:00:11 EST
The problem is also present in Seamonkey for FC10. I've attached a screenshot. I've also attached screenshots demonstrating the problem in GEDIT and OOWRITER. I noticed that I was able to reproduce the problem there as well. The font on the screen is liberation sans but the same thing happens with other fonts such as Arial taken directly from MS Windows.

Do you still want me to try firefox beta?
Comment 18 An. N 2008-12-09 18:01:44 EST
Created attachment 326422 [details]
blurry fonts in oowriter - notice the shaded I, or shades inside the H
Comment 19 An. N 2008-12-09 18:02:13 EST
Created attachment 326423 [details]
blurry fonts in gedit
Comment 20 An. N 2008-12-09 18:04:56 EST
Created attachment 326424 [details]
blurry fonts in seamonkey

completely unusable :(
Comment 21 Ben Laenen 2008-12-10 07:10:38 EST
Maybe you should get a copy of freetype that has the bytecode interpreter enabled so you don't have to use the freetype autohinter anymore. Using the truetype hinting instructions from the font itself will make it much more crisp.
Comment 22 Nicolas Mailhot 2008-12-10 07:25:42 EST
The reporter writes that the same fonts work fine in the rest of the desktop gui, that also uses the system freetype with autohinting.

Thus clearly the problem is not the system freetype or cairo libs, the problem lies in the way firefox uses them. Investigation will probably show that:
1. firefox fails to pass a crucial rendering parameter to one of the system libs, or
2. that since firefox insists on duplicating a private font configuration system in prefs.js (instead of using the desktop settings broadcasted via XSettings), it's missing one parameter which had been set desktop-side and not duplicated by the user manually in prefs.js.
Comment 23 An. N 2008-12-10 07:47:08 EST
Nicolas, please note that in recent updates I've also attached screenshots of other Gnome applications which are affected, the problem is not Firefox specific, however it is best visible in Firefox.

However, you still might be right. I'm not closely familiar with the structure of the font subsystem in Gnome.

More importantly, I have another system, a FC7 upgraded to FC10 and everything is fine there - fonts are less crisp than in MS Windows, but much better than on the attached screenshots and they're perfectly fine for daily usage. I don't understand where this difference in rendering comes from, since the system with the clean install is the one with the problems.

If this is not a freefont problem, where should this be reported?
Comment 24 Nicolas Mailhot 2008-12-10 09:09:48 EST
That's something else entirely, if the whole system behaves the same way, everything is probably working fine.

Font settings are highly subjective, their effects depend on the hardware you have, and what's best for one font won't necessarily be best for another, so two different systems, with different hardware, and defaults from different years, behaving differently, is most definitely NOTABUG.

If you prefer the old defaults you just have to copy them from the old system to the new one. Note however that unless the hardware is identical there is no warranty you'll find them as satisfying on one system compared to the other.
Comment 25 An. N 2008-12-10 10:10:41 EST
I see your point, however it most likely is not my case that you are writing about.

With all due respect, ever since I have filed this bug I have been treated like a novice. Please look again at the screenshots I've attached. The hardware correctly displays incorrect rendering, the hard evidence is on the images, which are screenshots, not photographs of my screen, so they look the same on any reasonable screen or graphics card.

I highly doubt that the rendering visible on my screenshots is intentional to make up for hardware deficiencies, and if it is, the software incorrectly recognizes the hardware as deficient.

Changing any setting - be it DPI, antialiasing, pixel order, font smoothing - yields worse results. Trust me, I've experimented with that a lot before deciding to bother people here at bugzilla, who already have a lot of other stuff to worry about.

Both systems I own have exactly the same font settings, although the hardware configurations are different, and that's because they give the best results. On both systems fonts look perfectly fine in MS Windows and Fedora 6 and Fedora 7, however on one of them Fedora 10 displays crap. Therefore, although I am aware that this might not be the case, I trust that there is no problem with my hardware (which is, on a side note, definitely not low end).

In essence, a fresh install of Fedora is nearly unusable for me because of this issue and I am willing to help you make it better, so that less people experience the problem. But I need assistance with that.
Comment 26 Nicolas Mailhot 2008-12-10 10:28:20 EST
I've seen the screenshots.

They don't correspond to my own preferences as displayed on my hardware (the rendering on another screen may be different depending on pixel density, RVB repartition, gamma settings, etc).

However as I wrote before those preferences are subjective and if there is one thing I've learnt since working on fonts is that if you show 3 different screenshots to three different people they'll all choose a different one as the crapiest and will be convinced the two others share their POW.

So that's not conclusive.

Post a screenshot of what you consider good and people like Behdad may tell you how to achieve this kind of rendering. I've stopped playing this game long ago.
Comment 27 Orion Poplawski 2008-12-10 10:37:11 EST
Can we please get this assigned to the proper component (and get me out of the loop)?
Comment 28 An. N 2008-12-10 17:04:28 EST
Ben: Many thanks for your advice. I recompiled freetype and I've included the bytecode interpreter. While not perfect, the fonts look MUCH better.

My original question, as to why they were ugly from the beginning (I guess many people would agree that what is on the screenshots is not very readable), remains unanswered.

Note You need to log in before you can comment on or make changes to this bug.