Bug 473842 - RFE: Add Greek Polytonic support to Liberation fonts
RFE: Add Greek Polytonic support to Liberation fonts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: FutureFeature, i18n, MoveUpstream, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 20:06 EST by Simos Xenitellis
Modified: 2014-04-23 01:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 05:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample Text with Polytonic Greek (18.45 KB, application/pdf)
2014-04-22 16:56 EDT, Alessandro Ceschini
no flags Details

  None (edit)
Description Simos Xenitellis 2008-11-30 20:06:27 EST
The Liberation fonts are missing the Greek Polytonic characters (Greek Extended Unicode group).

In practical terms, the Greek Extended Unicode group is made of the Greek characters with a variety of accents (they are precomposed characters).

This report is to track the process of adding support.
Comment 1 Caius Chance 2008-12-02 20:28:41 EST
Would you prefer to have 'Greek and Coptic Group' filled first? There are 45 chars to be worked.

And the Greek Extended Group has approximately 100 chars to be worked.

I am not from Greek so please let me know which group I should prioritize?

Thank you very much.
Comment 2 Simos Xenitellis 2008-12-02 21:55:18 EST
Yes, filling up the Greek Unicode block would be great.
We have updated the Greek layout (XKB) so that users can type these characters as well.

The section for Coptic (U03E2..U03EF) can be skipped because Coptic users make use of the dedicated Coptic Unicode block (starts at U2C80). I am not aware of Coptic documents that use Coptic from the Greek&Coptic Unicode block.

Cheers!
Comment 3 Caius Chance 2008-12-09 01:59:35 EST
Taken away Coptic letters (U03E2..U03EF), it has 30 chars remains.

30 chars * 3 types * 4 styles = 360 glyphs.

I don't think I could finish it alone timely. Could I know how many chars are needed to be filled, before Greek people could use this font? I can't promise how much I could do as I'm just 1 person. Let's try to prioritize it together.

I have read the Greek Extended block. Also, how important for Greek Extended block to Greek people?
Comment 4 Simos Xenitellis 2008-12-09 09:05:26 EST
The current set of glyphs in Liberation should be sufficient to Greek users.

Greek Polytonic and other Ancient characters should be useful to 
a. Scholars that study Classics and Ancient Greek (mostly Universities around the world)
b. People that study Biblical Greek. For example, see
http://www.nerdlets.org/category/greek/
c. Modern Greek replaced Greek Polytonic in 1981. There are people who continue to use Polytonic, as shown at http://www.polytoniko.org/

For a sample of users, see
http://simos.info/blog/archives/639

As a priority, I would consider Greek Polytonic to be 'Low priority' (I can only change Severity in this Bugzilla, not Priority).
Comment 5 Bug Zapper 2009-06-09 06:02:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Caius Chance 2009-06-30 22:51:55 EDT
Adding new glyphs is not planned at this stage.
Comment 7 Jens Petersen 2009-08-16 21:31:37 EDT
Unfortunately we don't have resources to do this work
but would appreciate any contributions to implement the glyphs.
Comment 8 Bug Zapper 2009-11-16 04:41:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Admin XMLRPC Client 2010-07-14 20:22:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Akira TAGOH 2011-06-10 03:56:12 EDT
We still have a problem on resources and this should be available and done for testing in rawhide first. moving back again and added a FutureFeature to prevent changing the version.
Comment 11 Pravin Satpute 2011-09-19 05:09:09 EDT
(In reply to comment #2)
> Yes, filling up the Greek Unicode block would be great.
> We have updated the Greek layout (XKB) so that users can type these characters
> as well.
> 
> The section for Coptic (U03E2..U03EF) can be skipped because Coptic users make
> use of the dedicated Coptic Unicode block (starts at U2C80). I am not aware of
> Coptic documents that use Coptic from the Greek&Coptic Unicode block.
> 
I am still not clear, exactly how many Unicode characters required in Liberation fonts for adding Greek Polytonic support

it will be nice if you can provide that information
Comment 12 Simos Xenitellis 2011-09-19 10:46:06 EDT
The characters that are needed are in the Greek Extended Unicode group,
http://www.unicode.org/charts/PDF/U1F00.pdf
and there are a couple of hundred of them.

The Greek Extended Unicode group contains 'pre-composed' characters only. That means, they are essentially the basic Greek vowels with one or more accents. There are nine accents in total for Greek Polytonic. So, for this work it just needs to take the Greek vowels from http://www.unicode.org/charts/PDF/U0370.pdf and add the diacritics (as required) from http://www.unicode.org/charts/PDF/U0300.pdf 
Sort of a large-scale copy-paste task.
Comment 13 Pravin Satpute 2011-09-20 00:23:57 EDT
Thanks Simos very clear now, lets see if we can find any volunteer for this.
Comment 14 Pravin Satpute 2012-08-07 14:26:47 EDT
Hi simos,
  We have support for Greek Polytonic in Liberation fonts version 2.00.0. Its already available in rawhide.

  You can install it manually from http://koji.fedoraproject.org/koji/buildinfo?buildID=344281
  

  Please test it and let me know if anything more required.
Comment 15 Pravin Satpute 2012-09-17 05:43:19 EDT
closing, please reopen if any problem.
Comment 16 Alessandro Ceschini 2014-04-22 16:56:55 EDT
Created attachment 888665 [details]
Sample Text with Polytonic Greek

I've just tested Liberation 2.0 with Polytonic Greek and it looks awesome! Kudos to Mr. Satpute, you did a wonderful job!
Comment 17 Pravin Satpute 2014-04-23 01:59:06 EDT
Thanks Alessandro :)

Note You need to log in before you can comment on or make changes to this bug.