Bug 473845 - iproute update does not update
iproute update does not update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 475491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 21:34 EST by Michal Jaegermann
Modified: 2008-12-09 23:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 23:38:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-11-30 21:34:09 EST
Description of problem:

An upgrade of F8 installation leaves an "orphaned", and with missing  dependencies, iproute package.  The problem is that the one on F8 is iproute-2.6.26-2.fc8, updated sometimes in November 2008, and the one which is supposed to replace it is iproute-2.6.26-1.fc10.  Results from yum are like this:

Setting up Local Package Process
Examining iproute-2.6.26-1.fc10.i386.rpm: iproute-2.6.26-1.fc10.i386
iproute-2.6.26-1.fc10.i386.rpm: does not update installed package.
Nothing to do

'rpm -Uvh --oldpackage iproute-2.6.26-1.fc10.i386.rpm ' does not work either because:

error: Failed dependencies:
        libatm.so.1 is needed by iproute-2.6.26-1.fc10.i386

Only after 'yum install /usr/lib/libatm.so.1', which installs missing linux-atm-libs, an "--oldpackage" saves the situation.

Version-Release number of selected component (if applicable):
iproute-2.6.26-1.fc10

Additional info:
That will be not an issue with F9->F10 updates as iproute in F9 is currently iproute-2.6.25-1.fc9 but an upgrade F8->F9 will bump into the same trouble.
Comment 1 Marcela Mašláňová 2008-12-03 10:14:03 EST
I didn't find anything wrong with spec file. There was simple added new BuilRequires linux-atm-libs, after which is possible install two more files. But that shouldn't be issue, because those files are installed in directories, which are used anyway.
Comment 2 Panu Matilainen 2008-12-03 10:29:04 EST
F8 has newer version-release of iproute than F10, so it fails to upgrade correctly.

This is an packaging issue, not rpm bug.
Comment 3 Marcela Mašláňová 2008-12-03 10:40:21 EST
Omg. I missed this one. Thank you.
Comment 4 Fedora Update System 2008-12-04 05:13:55 EST
iproute-2.6.27-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/iproute-2.6.27-1.fc10
Comment 5 Fedora Update System 2008-12-06 23:25:20 EST
iproute-2.6.27-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iproute'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10847
Comment 6 Marcela Mašláňová 2008-12-09 08:59:46 EST
*** Bug 475491 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-12-09 23:38:13 EST
iproute-2.6.27-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.