Bug 473873 - cman_tool segfaults on "cman_tool nodes -F id,name,type,addr"
cman_tool segfaults on "cman_tool nodes -F id,name,type,addr"
Status: CLOSED DUPLICATE of bug 472460
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 03:03 EST by Baptiste Mille-Mathias
Modified: 2009-04-16 18:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 06:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baptiste Mille-Mathias 2008-12-01 03:03:40 EST
Description of problem:

[root@sa-nas001-wb1 www]# cman_tool nodes -F id,name,type,addr
Segmentation fault

Version-Release number of selected component (if applicable):
cman-2.0.84-2.el5_2.2

How reproducible:
100%

Steps to Reproduce:
weirdly it crashes only when I gives all possible arguments 
[root@sa-nas001-wb1 www]# cman_tool nodes -F id
0 
1 
2 
[root@sa-nas001-wb1 www]# cman_tool nodes -F id,name
0 /dev/sdb 
1 sa-nas001-wb1 
2 sa-nas001-wb3 
[root@sa-nas001-wb1 www]# cman_tool nodes -F id,name,type
0 /dev/sdb M 
1 sa-nas001-wb1 M 
2 sa-nas001-wb3 M 
[root@sa-nas001-wb1 www]# cman_tool nodes -F id,name,type,addr
Segmentation fault

a strace log, gdb doesn't provide any useful information
[root@sa-nas001-wb1 www]# strace cman_tool nodes -F id,name,type,addr
execve("/usr/sbin/cman_tool", ["cman_tool", "nodes", "-F", "id,name,type,addr"], [/* 24 vars */]) = 0
brk(0)                                  = 0x16ee7000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2af548c77000
uname({sys="Linux", node="sa-nas001-wb1.nas001.sys", ...}) = 0
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=131418, ...}) = 0
mmap(NULL, 131418, PROT_READ, MAP_PRIVATE, 3, 0) = 0x2af548c78000
close(3)                                = 0
open("/lib64/libc.so.6", O_RDONLY)      = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\260\331!\357:\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1699912, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2af548c99000
mmap(0x3aef200000, 3481848, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x3aef200000
mprotect(0x3aef34a000, 2093056, PROT_NONE) = 0
mmap(0x3aef549000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x149000) = 0x3aef549000
mmap(0x3aef54e000, 16632, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x3aef54e000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2af548c9a000
arch_prctl(ARCH_SET_FS, 0x2af548c9a220) = 0
mprotect(0x3aef549000, 16384, PROT_READ) = 0
mprotect(0x3aef01a000, 4096, PROT_READ) = 0
munmap(0x2af548c78000, 131418)          = 0
brk(0)                                  = 0x16ee7000
brk(0x16f08000)                         = 0x16f08000
socket(PF_FILE, SOCK_STREAM, 0)         = 3
fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
connect(3, {sa_family=AF_FILE, path="/var/run/cman_client"}, 110) = 0
open("/dev/zero", O_RDONLY)             = 4
writev(3, [{"NAMC\3\0\0\20\24\0\0\0\7\0\0\0\0\0\0\0", 20}], 1) = 20
writev(3, 0x7fff61e31e30, 18446744073709551615) = -1 EINVAL (Invalid argument)
recvfrom(3, "NAMC:\0\0\0@\5\0\0\7\0\0@\0\0\0\0", 20, 0, NULL, NULL) = 20
read(3, "\3\0\0\0\270\1\0\0\1\0\0\0\1\0\0\0\0\0\0\0\320\0\0\0\2\0\0\0sa-n"..., 1324) = 1324
writev(3, [{"NAMC\3\0\0\20\24\0\0\0\7\0\0\0\0\0\0\0", 20}], 1) = 20
recvfrom(3, "NAMC:\0\0\0@\5\0\0\7\0\0@\0\0\0\0", 20, 0, NULL, NULL) = 20
read(3, "\3\0\0\0\270\1\0\0\1\0\0\0\1\0\0\0\0\0\0\0\320\0\0\0\2\0\0\0sa-n"..., 1324) = 1324
writev(3, [{"NAMC\3\0\0\20\24\0\0\0\7\0\0\0\0\0\0\0", 20}], 1) = 20
recvfrom(3, "NAMC:\0\0\0@\5\0\0\7\0\0@\0\0\0\0", 20, 0, NULL, NULL) = 20
read(3, "\3\0\0\0\270\1\0\0\1\0\0\0\1\0\0\0\0\0\0\0\320\0\0\0\2\0\0\0sa-n"..., 1324) = 1324
open("/etc/localtime", O_RDONLY)        = 5
fstat(5, {st_mode=S_IFREG|0644, st_size=157, ...}) = 0
fstat(5, {st_mode=S_IFREG|0644, st_size=157, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2af548c78000
read(5, "TZif2\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\2\0\0\0\2\0\0\0\0"..., 4096) = 157
lseek(5, -84, SEEK_CUR)                 = 73
read(5, "TZif2\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\2\0\0\0\2\0\0\0\0"..., 4096) = 84
close(5)                                = 0
munmap(0x2af548c78000, 4096)            = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=157, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=157, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=157, ...}) = 0
writev(3, [{"NAMC\3\0\0\20\30\0\0\0\277\0\0\0\0\0\0\0", 20}, {"\0\0\0\0", 4}], 2) = 24
recvfrom(3, "NAMC\0\0\0\0\30\0\0\0\277\0\0@\0\0\0\0", 20, 0, NULL, NULL) = 20
read(3, "\352\377\377\377", 4)          = 4
fstat(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 4), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2af548c78000
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 1 Christine Caulfield 2008-12-01 06:46:25 EST

*** This bug has been marked as a duplicate of bug 472460 ***

Note You need to log in before you can comment on or make changes to this bug.