Bug 473904 - Stop key recognised as Cancel
Stop key recognised as Cancel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 07:16 EST by Julian Sikorski
Modified: 2008-12-16 04:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 04:08:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (133.24 KB, text/plain)
2008-12-01 07:16 EST, Julian Sikorski
no flags Details
xkbcomp output (47.21 KB, text/plain)
2008-12-03 02:38 EST, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2008-12-01 07:16:47 EST
Created attachment 325224 [details]
lshal output

Description of problem:
In a Toshiba Satellite A100-847 laptop, pressing Stop multimedia key emits Cancel event, while it should emit XF86AudioStop.

Version-Release number of selected component (if applicable):
hal-info-20081022-1.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. Get the said laptop
2. Install Fedora 10
3. Press the Stop key
  
Actual results:
Cancel is emitted

Expected results:
XF86AudioStop is emitted

Additional info:
lshal output is attached.
Comment 1 Richard Hughes 2008-12-01 08:22:05 EST
      <match key="/org/freedesktop/Hal/devices/computer:system.hardware.vendor" string="TOSHIBA">
        <match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" string="SATELLITE A100">
          <append key="input.keymap.data" type="strlist">e024:stop</append>
          <append key="input.keymap.data" type="strlist">e032:www</append>
        </match>
      </match>

It looks like HAL sets the stop key. What key should be used from /usr/include/linux/input.h ? 

Could this be a evdev mapping problem? Peter?
Comment 2 Peter Hutterer 2008-12-02 18:49:34 EST
Please attach the output of xkbcomp -xkb :0 -, and what specific keycode you actually get (just run xev, it'll tell you when you hit the key).

Looking at /usr/share/X11/xkb/symbols/inet, STOP is mapped to Cancel and the key that's using XF86AudioStop is STOPCD. Could this be a hal-info mapping wrongly?
Comment 3 Julian Sikorski 2008-12-03 02:38:18 EST
Created attachment 325494 [details]
xkbcomp output

KeyPress event, serial 30, synthetic NO, window 0x5600001,
    root 0x1a6, subw 0x0, time 579672, (391,321), root:(394,392),
    state 0x10, keycode 136 (keysym 0xff69, Cancel), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x5600001,
    root 0x1a6, subw 0x0, time 579682, (391,321), root:(394,392),
    state 0x10, keycode 136 (keysym 0xff69, Cancel), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 4 Julian Sikorski 2008-12-03 03:25:13 EST
Here is what evtest.c shows:
Event: time 1228292487.111235, type 4 (Misc), code 4 (ScanCode), value a4
Event: time 1228292487.111257, type 1 (Key), code 128 (Stop), value 0
Event: time 1228292487.111261, -------------- Report Sync ------------
Comment 5 Peter Hutterer 2008-12-04 00:42:22 EST
right, this key should be mapped to stopcd instead of stop.
Comment 6 Julian Sikorski 2008-12-12 10:13:52 EST
I can confirm that changing the entry in fdi file to stopcd solves the issue. Any chances for this being merged?
Comment 7 Julian Sikorski 2008-12-16 04:08:21 EST
The fix has been committed upstream.

Note You need to log in before you can comment on or make changes to this bug.