Bug 473908 - Logitech Alto Cordless emits wrong events for two buttons
Logitech Alto Cordless emits wrong events for two buttons
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 07:27 EST by Julian Sikorski
Modified: 2009-04-28 17:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 17:15:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (467 bytes, text/plain)
2008-12-05 10:26 EST, Julian Sikorski
no flags Details
Xorg.0.log (17.67 KB, text/plain)
2008-12-05 10:27 EST, Julian Sikorski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 12238 None None None Never

  None (edit)
Description Julian Sikorski 2008-12-01 07:27:22 EST
Description of problem:
When Fn-F3 is pressed, XF86HomePage is emitted, while XF86WWW would be more appropriate (the icon on the button is the MSIE logo). Similarly, for Fn-F4 XF86Tools is emitted instead of XF86Media (a tune icon is on the button). I am using evdev-managed keyboard layout.

Version-Release number of selected component (if applicable):
xkeyboard-config-1.4-4.fc10.noarch

How reproducible:
always
Comment 1 Julian Sikorski 2008-12-01 08:08:30 EST
Wait, nim-nim told me to check if the device conforms with the standards first.
Comment 2 Julian Sikorski 2008-12-03 03:58:23 EST
evtest reports the following:

Event: time 1228294575.277680, type 4 (Misc), code 4 (ScanCode), value c0223
Event: time 1228294575.277708, type 1 (Key), code 172 (HomePage), value 1
Event: time 1228294575.277716, -------------- Report Sync ------------
Event: time 1228294575.437667, type 4 (Misc), code 4 (ScanCode), value c0223
Event: time 1228294575.437692, type 1 (Key), code 172 (HomePage), value 0
Event: time 1228294575.437699, -------------- Report Sync ------------
Event: time 1228294576.165695, type 4 (Misc), code 4 (ScanCode), value c0183
Event: time 1228294576.165724, type 1 (Key), code 171 (Config), value 1
Event: time 1228294576.165732, -------------- Report Sync ------------
Event: time 1228294576.325660, type 4 (Misc), code 4 (ScanCode), value c0183
Event: time 1228294576.325690, type 1 (Key), code 171 (Config), value 0
Event: time 1228294576.325697, -------------- Report Sync ------------
Comment 3 Matěj Cepl 2008-12-05 09:59:18 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Julian Sikorski 2008-12-05 10:26:31 EST
Created attachment 325856 [details]
xorg.conf
Comment 5 Julian Sikorski 2008-12-05 10:27:59 EST
Created attachment 325857 [details]
Xorg.0.log

As you wish.
Comment 6 Julian Sikorski 2008-12-05 10:30:45 EST
Please note that there are 4 Logitech USB Receivers, two for my mouse and two for the alto cordless - for each of the physical devices you have one mouse device and one keyboard device. Don't ask me why.
Comment 7 Peter Hutterer 2008-12-07 19:52:48 EST
Moving this one to hal-info, looks like the keyboard needs a quirk to remap the keycodes.

See also: http://people.freedesktop.org/~hughsient/quirk/quirk-keymap-index.html
Comment 8 Julian Sikorski 2008-12-16 05:37:36 EST
USB keyboards are quirked in kernel. Reassinging.

Note You need to log in before you can comment on or make changes to this bug.