Bug 473910 - guest keyboard unusable with layout switching using both Shift keys
guest keyboard unusable with layout switching using both Shift keys
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 07:41 EST by Miloslav Trmač
Modified: 2008-12-21 03:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:34:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-12-01 07:41:30 EST
Version-Release number of selected component (if applicable):
kvm-74-6.fc10.x86_64
virt-manager-0.6.0-3.fc10.x86_64

Steps to Reproduce:
(Tested with a Czech locale, the labels may not match exactly)
1. Open System/Settings/Hardware/Keyboard
2. On the layout tab, click on "Restore default" (only one USA layout)
3. "Add" a layout: Czech Republic, Czechia qwerty
4. In "Layout options", set:
   Ctrl key position - Make CapsLock an additional Ctrl
   Layout switching - R-Alt switches layout while pressed
   Use keyboard LED to show alternative layout - CapsLock LED shows ...
   (perhaps none of these are relevant - but this is the environment I use)
5. Start virt-manager, install a rhel5 guest, start it, switch to console
   Try typing "rhn_register", verify it works as expected
6. In "Layout options" as above, set:
   Layout switching - Both Shift keys together change layout
7. Start the rhel5 guest again (or continue using the previous sesssion).
   Try typing rhn_register.
  
Actual results:
Shift key release ignored, so the result is rhn_REGISTER.
The following messages appear in the console:

  atkbd.c: Unknown key released (translated set 2, code 0x0 on isa0060/serio0).
  atkbd.c: Use 'setkeycodes 00 <keycode>' to make it known.

Expected results:
Shift key release handled as expected.
Comment 1 Miloslav Trmač 2008-12-08 09:57:00 EST
This might be caused by keysyms in the keyboard layout:

Press left shift:
KeyPress event, serial 27, synthetic NO, window 0x4600001,
    root 0x7f, subw 0x0, time 4530759, (41,81), root:(44,658),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

Release left shift:
KeyRelease event, serial 30, synthetic NO, window 0x4600001,
    root 0x7f, subw 0x0, time 4530806, (41,81), root:(44,658),
    state 0x1, keycode 50 (keysym 0xfe0a, ISO_Prev_Group), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Press right shift:
KeyPress event, serial 30, synthetic NO, window 0x4600001,
    root 0x7f, subw 0x0, time 4533907, (41,81), root:(44,658),
    state 0x0, keycode 62 (keysym 0xffe2, Shift_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

Release right shift:
KeyRelease event, serial 30, synthetic NO, window 0x4600001,
    root 0x7f, subw 0x0, time 4533986, (41,81), root:(44,658),
    state 0x1, keycode 62 (keysym 0xfe08, ISO_Next_Group), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 2 Daniel Berrange 2008-12-08 10:08:36 EST
Can you give these packages a try and say if they make any useful difference

http://kojipkgs.fedoraproject.org/packages/gtk-vnc/0.3.8/1.fc11/

Key modifier handling in VNC is a trainwreck, and this new release tries to un-wreck things in a different way to current F10 gtk-vnc. Its 50/50 whether it actually helps you though....
Comment 3 Miloslav Trmač 2008-12-08 11:32:00 EST
Yes, 0.3.8 that seems to work fine.
Comment 4 Daniel Berrange 2008-12-09 06:36:10 EST
Built for both F10 and F9  into gtk-vnc-0.3.8-1.fc10/fc9
Comment 5 Fedora Update System 2008-12-09 06:40:23 EST
gtk-vnc-0.3.8-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtk-vnc-0.3.8-1.fc10
Comment 6 Fedora Update System 2008-12-09 23:39:41 EST
gtk-vnc-0.3.8-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11128
Comment 7 Fedora Update System 2008-12-21 03:34:06 EST
gtk-vnc-0.3.8-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.