Bug 473917 - [NetApp 5.3 bug] inbox qla2xxx driver is not FCoE ready
[NetApp 5.3 bug] inbox qla2xxx driver is not FCoE ready
Status: CLOSED DUPLICATE of bug 472382
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
high Severity urgent
: rc
: ---
Assigned To: Marcus Barrow
Martin Jenner
: OtherQA
Depends On:
Blocks: 373081 415811
  Show dependency treegraph
 
Reported: 2008-12-01 08:30 EST by Martin George
Modified: 2009-06-20 04:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 17:05:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin George 2008-12-01 08:30:25 EST
Description of problem:
The bundled QLogic FC driver v8.02.00.05.05.03-k available in the RHEL 5.3 snapshot4 kernel is not FCoE (Fibre Channel Over Ethernet) ready. This host with the QLE8042 CNA when connected to a Cisco Nexus 5020 switch fails to initialize during the driver reload. 


Config details:
Host:
RHEL 5.3 Snapshot4 (2.6.18-124.el5) with bundled QLogic driver v8.02.00.05.05.03-k and QLE8042 CNA running fw v4.04.05 & BIOS v2.03

FCoE switch:
Cisco Nexus 5020 running 4.0(0)N1(2) & BIOS v1.2.0


Additional info:
On the same host, the external QLogic driver v8.02.14.01.2 works fine when connected to the FCoE fabric i.e. the issue is seen only with the bundled QLogic driver available on RHEL 5.3.
Comment 1 Andrius Benokraitis 2008-12-01 08:59:51 EST
Including QLogic for comment. Marcus? This doesn't look too good if true...
Comment 2 Marcus Barrow 2008-12-01 09:32:50 EST

We just got RedHat's FCOE switch running last week. THe QLA driver brings up it's link and talks with the switch but doesn't find any LUNS. I don't know why yet. We don't know much about this switch...

It took way more more effort to get the switch going then we expected.

I haven't talked with any folks about this yet, but am thinking we will coninue working on the driver and need to deliver it as a kmod before/when 5.4 ships? I don't know how many days it will take to find this last issue, but want a backup plan...
Comment 3 Martin George 2008-12-01 10:15:11 EST
(In reply to comment #2)
> 
> We just got RedHat's FCOE switch running last week. THe QLA driver brings up
> it's link and talks with the switch but doesn't find any LUNS. I don't know why
> yet. We don't know much about this switch...

What FCoE switch/firmware are you using? In my setup, the link state always shows up as "Link Down" (at
/sys/class/scsi_host/host<num>/state) with the bundled driver connected to the Cisco Nexus switch which points to basic fabric initialization issues. The same shows up as "running" with the external driver.
Comment 4 Marcus Barrow 2008-12-01 16:35:02 EST
Hi Martin, thanks for reporting this. I have the same behaviour until I apply the patch in this BZ 472382. I have added you to the cc list on that BZ. COuld you try the patch attached there and let me know if that helps. If you can't get the patch I will email it to you...

Thnaks
Comment 5 Andrius Benokraitis 2008-12-01 17:05:13 EST
Martin, please re-open this if it is indeed new behavior.

*** This bug has been marked as a duplicate of bug 472382 ***

Note You need to log in before you can comment on or make changes to this bug.