Bug 473937 - NetPanzer doesn't start
NetPanzer doesn't start
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 10:01 EST by Γριφεγ Γ.
Modified: 2009-04-06 10:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 10:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Γριφεγ Γ. 2008-12-01 10:01:38 EST
Description of problem:
$ netpanzer 
ALSA lib pcm_pulse.c:629:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

E: stream.c: Assertion 's' failed at pulse/stream.c:1224, function pa_stream_drain(). Aborting.
Received signal SIGABRT(6)
aborting and trying to shutdown.
Aborted


Version-Release number of selected component (if applicable):
netpanzer-0.8.2-3.fc9.i386


Additional info:
Sound through PulseAudio really slows down NetPanzer anyway (half the FPS).
Comment 1 Gwyn Ciesla 2008-12-01 10:26:15 EST
Reassigning, part of larger PA issues.
Comment 2 Lennart Poettering 2008-12-08 14:38:25 EST
There seems to be now audio device available in PA when this happens. 

Of course the pa plugin for alsa shouldn't crash in this case. But I am quite sure this is actually an ALSA misusage. (i.e. some alsa function is called on an invalid ALSA PCM handle).

I'll check out whether we actually mishandle things here in the plugin for alsa.
Comment 3 Matthias Clasen 2009-02-05 22:35:07 EST
Did you check it out, Lennart ?
Comment 4 Matthias Clasen 2009-04-06 00:54:00 EDT
Lennart ?
Comment 5 Lennart Poettering 2009-04-06 10:24:44 EDT
The assert has been fixed a while back in the alsa plugin.

Note You need to log in before you can comment on or make changes to this bug.