Bug 473946 - xgettext misinterprets \x escapes in Python Unicode strings
xgettext misinterprets \x escapes in Python Unicode strings
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 10:34 EST by Matěj Cepl
Modified: 2009-05-29 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.17-10.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 22:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 433743 None None None Never
Debian BTS 493218 None None None Never

  None (edit)
Description Matěj Cepl 2008-12-01 10:34:03 EST
Description of problem:
When trying to update po files in gajim, I got this error:

[matej@viklef po]$ make update-po
make gajim.pot
make[1]: Entering directory `/home/matej/redhat/BUILD/gajim/po'
INTLTOOL_EXTRACT=/usr/bin/intltool-extract srcdir=. /usr/bin/intltool-update --gettext-package gajim --pot
./../src/common/config.py:180: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                        The translator cannot reorder the arguments.
                                        Please consider using a format string with named arguments,
                                        and a mapping instead of a tuple for the arguments.
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
make[1]: *** [gajim.pot] Error 1
make[1]: Leaving directory `/home/matej/redhat/BUILD/gajim/po'
make: *** [update-po] Error 2
[matej@viklef po]$ 

When I filed my ticket (which was closed as duplicate of http://trac.gajim.org/ticket/4166), I was told that it is actually bug in xgettext which has been already fixed in Debian (bugs.debian.org/433743 and bugs.debian.org/493218).

I have no idea, whether they sent patches upstream.

Version-Release number of selected component (if applicable):
gettext-0.17-8.fc10.i386

How reproducible:
100%
Comment 1 Jens Petersen 2009-02-12 01:19:00 EST
As far as I can tell the first patch (in debian#433743) is already installed upstream in 0.17.

I am adding the second one from debian#493218 in gettext-0.17-9.fc11.

Can you please change that that solves the problem for you?  Thanks.
Comment 2 Matěj Cepl 2009-03-05 04:14:02 EST
Yes, gettext-0.17-9.fc11 works. Please, build it for F10 as well.

Thank you
Comment 3 Jens Petersen 2009-03-05 22:58:42 EST
Thanks - then moving to F10.
Comment 5 Fedora Update System 2009-05-22 04:03:43 EDT
gettext-0.17-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gettext-0.17-10.fc10
Comment 6 Fedora Update System 2009-05-25 17:07:09 EDT
gettext-0.17-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gettext'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5338
Comment 7 Fedora Update System 2009-05-29 22:31:34 EDT
gettext-0.17-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.