Bug 473969 - Problem with konsole/su and starting applications
Problem with konsole/su and starting applications
Status: CLOSED DUPLICATE of bug 473465
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 11:55 EST by Sammy
Modified: 2008-12-01 13:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 12:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2008-12-01 11:55:11 EST
Using KDE-4.1.3 f9 + updates.

PROBLEM 1:
If I su to root from a konsole session and start a graphical application
it fails to open a window on my screen even though it is running.

PROBLEM 2:
If I start system-config-printer from the menus it starts fine. But if I start
it as above  from the konsole session. I get:
===============================================================================
raceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 5537, in <module>
    main(configure_printer, change_ppd, devid)
  File "/usr/share/system-config-printer/system-config-printer.py", line 5502, in main
    mainwindow = GUI(configure_printer, change_ppd, devid)
  File "/usr/share/system-config-printer/system-config-printer.py", line 576, in __init__
    self.populateList()
  File "/usr/share/system-config-printer/system-config-printer.py", line 975, in populateList
    default_emblem = theme.load_icon (emblem, w/2, 0)
gobject.GError: Icon 'emblem-default' not present in theme
================================================================================

It seems like konsole is not setting some environment variable.
THanks
Comment 1 Kevin Kofler 2008-12-01 12:48:08 EST
You cannot launch graphical apps in su.

*** This bug has been marked as a duplicate of bug 473465 ***
Comment 2 Sammy 2008-12-01 13:30:54 EST
since when? I always did this and can still do it for most.
For example I can run all my x-based applications or even
some gtk ones like "system-config-date" and they show up OK,
However, some do not. Examples are konqueror, firefox, and 
the one above.

Note You need to log in before you can comment on or make changes to this bug.