Bug 473993 - Evolution Error: Check Junk Failed Pipe to SpamAssassin failed, error code: 1
Evolution Error: Check Junk Failed Pipe to SpamAssassin failed, error code: 1
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 13:27 EST by Scott Glaser
Modified: 2008-12-01 14:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 14:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of the error Message (174.62 KB, image/png)
2008-12-01 13:29 EST, Scott Glaser
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 560420 None None None Never

  None (edit)
Description Scott Glaser 2008-12-01 13:27:33 EST
Description of problem: During the process of filtering the messages from mbox, the triangular warning reporting 'Check junk Failed' appears.

COMMENTS: Obviously, some of the items in mbox are being correctly processed
and some are obviously not. That is why I find the 'Pipe to Spamassassin failed
- error code 1" troublesome. It is almost as if there is some kind of a locking
or synching mechanism behind the problem, otherwise would not the pipe fail on
every instance, which is clearly not the case.

UPSTREAM? This problem has been reported in other distros as per google
searching, but problems seem to go unresolved or referred to the various
distros.

Version-Release number of selected component (if applicable):

evolution-perl-2.24.1-2.fc10.i386
evolution-rspam-0.0.6-4.fc10.i386
evolution-2.24.1-2.fc10.i386
evolution-help-2.24.1-2.fc10.i386
evolution-spamassassin-2.24.1-2.fc10.i386
evolution-webcal-2.23.91-1.fc10.i386
evolution-data-server-2.24.1-2.fc10.i386
spamassassin-3.2.5-2.fc10.i386


How reproducible:

Very reproducible.

Steps to Reproduce:
1. Click Send/Receive Email
2. As the mail is processed the following message is displayed: Check Junk Failed Pipe to SpamAssassin failed, error code: 1

Actual results:

Message: Check Junk Failed Pipe to SpamAssassin failed, error code: 1  is displayed

Expected results:

Expect Junk mail to be processed by spamassassin


Additional info:
Comment 1 Scott Glaser 2008-12-01 13:29:27 EST
Created attachment 325279 [details]
Image of the error Message
Comment 2 Matthew Barnes 2008-12-01 14:03:09 EST
Thanks for the bug report.  This issue has been reported upstream, so I'll refer you to the GNOME bug report where you can continue tracking the issue.

Basically the issue is only error codes >= 64 actually indicate an error.  Lower numbered positive codes indicate the checked mail is indeed spam.  Evolution is misinterpreting any non-zero error code as indicating an error.

For more details, see: http://bugzilla.gnome.org/show_bug.cgi?id=560420

Note You need to log in before you can comment on or make changes to this bug.