Bug 474025 - Keyboard layout switching stops working
Keyboard layout switching stops working
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-01 14:48 EST by Mikkel Lauritsen
Modified: 2009-12-23 02:29 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mikkel Lauritsen 2008-12-01 14:48:22 EST
I have two keyboard layouts selected, US English (default) and Danish, and I have added the Keyboard Indicator applet to the Panel.

Sometimes switching the keyboard layout using the applet or the key combination chosen in Keyboard Preferences stops working. Unfortunately I'm unable to provide an exact reproduction scenario but it seems to happen when I leave the machine running over the night. Manually locking the screen does not trigger the problem.

The problem has always happened when the default layout is selected but that might be a coincidence. In some cases I have experienced that the applet changes to show only ??? instead of the name of the layout.

If I re-add the Danish layout (so it shows twice in the list) and immediately remove it again switching starts working again. Logging out and logging in again also makes switching work again.

Version-Release number of selected component (if applicable):
gnome-applets-2.24.1-1.fc10.x86_64 from fully updated F10.
Comment 1 Mikkel Lauritsen 2008-12-01 14:49:40 EST
Related to bug 473837? In my case I have the "separate layout for each window" option checked, so it's not the exact same problem.
Comment 2 Ray Strode [halfline] 2008-12-01 16:16:34 EST
Could it be after a suspend-resume cycle?
Comment 3 Mikkel Lauritsen 2008-12-02 00:24:01 EST
Unfortunately no; it's a desktop machine that I never suspend.

BTW, the current install is the result of installing and upgrading from F10 Beta. I have experienced the problem before the final release but less frequently (so I didn't think of reporting it :-/), but that might just be a result of changed usage patterns.
Comment 4 denis ivanov 2008-12-11 10:17:07 EST
The same kind of bug happens on my computer.


X server running without /etc/X11/xorg.conf (i810 videocard)

When I disconnect/connect external USB keyboard, the layout switcher combination (CapsLock) seems as deactivated. Only one way I found to re-activate ability to switch layouts is going to keyboard preferences, layout switch options, and uncheck/check "CapsLock switches layouts" option.

Important note: when this problem happens with external keyboard, internal laptop keyboard switches without any problems. And the most interesting thing:  when I switch layout by internal keyboard and typing text from it it's ok and russian letters coming to input but external keyboard keep typing latin letters...

Have found some bugs at gnome bugzilla maybe connected with this issue:
http://bugzilla.gnome.org/show_bug.cgi?id=549267 (usb mouse issue)
Comment 5 denis ivanov 2008-12-18 11:42:34 EST

The same result with just updated X server.
Comment 6 denis ivanov 2008-12-21 10:54:58 EST
Today tried this bug with default FC10 installation because my computer was originally upgraded from FC9.

Loaded Live CD with GNOME - the same issue
and........ loaded Live CD with KDE 

Got the same problem !!!

External USB keyboard forget it's layout after reconnection.

Seems this is not gnome-settings-daemon issue only.

Please help.
Comment 7 denis ivanov 2008-12-21 12:00:40 EST
New update: when I started laptop without external keyboard, layouts is ok (for internal keyboard). But later I'm connected external keyboard and it works with default layout only until I open and change anything in keyboard layout properties.

Also I have i586 not x86_64 platform, so please update bug information.
Comment 8 denis ivanov 2009-01-16 02:29:59 EST
PLEASE change bug platform and set high priority.

Also please somebody confirm this bug on another machines.

Comment 9 Roland Roberts 2009-01-29 13:15:58 EST
I have a Dell Latitude D820 Laption, like denis ivanov, I see the same symptoms.  My laptop is moved daily between docking stations.  Each time, I have to re-open the gnome keyboard layout, the settings are correct, but I have to change them, change them back, the save.  Anything less and the settings do not take effect.  All I am changing is the swap capslock and control option.

271 roland> uname -r

The keyboard layout on the laptop itself is fine.

On docking station goes through a KVM, the other does not.  Both display the same problem.
Comment 10 Valerie Aurora Henson 2009-02-17 23:05:32 EST
I see the same bug as Denis Ivanov.  I have a Dell XPS 1330 and I decided to try remapping CapsLock to Control using Gnome's keyboard preferences app.  When I unplug and replug the USB keyboard, CapsLock on the USB keyboard reverts back to CapsLock (on the builtin keyboard, it stays put).  Opening up keyboard preferences and clicking on "Default" and then "Make CapsLock an additional Ctrl" gets it back to the preferred state.

Back to (sigh) xmodmap.  The keyboard preferences GUI was much nicer, I'm glad it exists and I can't wait to use it again.
Comment 11 Valerie Aurora Henson 2009-02-18 01:08:40 EST
Version info might help!  I just upgraded to the latest of everything as of 2/17/2009 and the bug is still present.


[val@clunky ~]$ uname -r
Comment 12 denis ivanov 2009-02-18 01:18:44 EST
The same with i386 arch:


Bug present from first days of Fedora 10.
Guys please do not allow it in next Fedora release. ;-)))
Comment 13 Garrett Mitchener 2009-02-24 11:52:37 EST
I'm seeing this as well.  I have an up-to-date fedora 10 x86_64 installation, upgraded from 8, and I use gnome.  I recently got rid of all my old ~/.gnome* files and started fresh, which fixed some other things that were going wrong, but I'm seeing these keyboard problems.  I use a Logitech wave wireless USB keyboard and mouse.

My xorg.conf file is nonexistant -- the X server detects everything automatically.  I have no ~/.xmodmap.

I used the keyboard preferences GUI to make the caps lock key into an extra control key, and to set the right control key to switch between qwerty and Dvorak layouts.

If I leave myself logged in over night, when I come back in the morning, the control key setting reverts and the dvorak layout stops working.  As in, neither the right control key nor clicking on the layout indicator in the panel makes it switch layouts.  If I open the GUI, all of my settings are still as I set them, they're just not working.  If I change something and then close the GUI, the settings take effect again.  Unplugging and replugging the keyboard USB dongle doesn't seem to make a difference.

Also, I want to use the same keyboard layout for every window, that is, I unset the "separate layout for each window" box, but I seem to be getting per-window layouts anyway.  I think the per-window layout behavior might be a compiz bug, because I don't remember this happening when I used metacity.
Comment 14 Roland Roberts 2009-03-04 22:35:04 EST
The keyboard mapping problem does not show up if I boot while the laptop is in the docking station (which is attached to the external keyboard).  It only shows up after a suspend-resume cycle.  I haven't tried the USB unplug/plugin sequence to know if that triggers it, too.
Comment 15 Allen McIntosh 2009-04-14 16:59:08 EDT
I can confirm that when my keyboard drops off the USB bus and comes back the results of any local xmodmap have been forgotten.  Specifically, I disable the caps lock key.  When I use my USB KVM to move the keyboard elsewhere and move it back, caps lock has risen from the dead.  (The KVM does not do keyboard emulation.)

Relevant(?) RPM's (I just updated the world this morning)


I used to use xorg.conf to accomplish the same thing, but there is no xorg.conf in FC10.
Comment 16 Roland Roberts 2009-10-14 16:48:40 EDT
FWIW, this appears to be working correctly in F11.
Comment 17 Bug Zapper 2009-11-18 05:15:40 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 18 Bug Zapper 2009-12-18 02:05:25 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 19 Abhishek Singh 2009-12-23 02:29:18 EST
I'm facing the same problem on my Fedora 11 machine. It used to work before, but since a week, it has stopped working. I'm using two layouts "USA" and "Nepal". But when I right click on the applet and hover over "Groups", it shows "USA" only. Meanwhile it is unable to switch layouts. But as soon as I go to "Keyboard Preferences", it displays both the layouts in the "Layouts" tab. And from then, layout switching starts working. The same problem repeats when I reboot the computer. Seems like at the startup, the layout indicator is unable to recognize that more than one layouts are in use.

Note You need to log in before you can comment on or make changes to this bug.