Bug 474035 - Resuming from suspend freezes the machine with garbled display
Resuming from suspend freezes the machine with garbled display
Status: CLOSED DUPLICATE of bug 473195
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 15:06 EST by Mikkel Lauritsen
Modified: 2008-12-04 02:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 02:35:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (71.92 KB, text/plain)
2008-12-01 15:06 EST, Mikkel Lauritsen
no flags Details
pm-suspend log file (4.54 KB, text/plain)
2008-12-01 15:06 EST, Mikkel Lauritsen
no flags Details

  None (edit)
Description Mikkel Lauritsen 2008-12-01 15:06:09 EST
Created attachment 325287 [details]
Xorg log file

Fully updated F10 on a Dell Inspiron 6400 with Radeon Mobility X1400.

Suspending the machine seems to work fine, ending up in a powered off state with the power LED pulsing as expected. When I try to resume it hangs (no response from Caps/Num Lock, no network activity) and the display shows a garbled version of the proper screen contents.

This is completely reproduceable.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-54.fc10.i386
kernel-2.6.27.5-117.fc10.i686
Comment 1 Mikkel Lauritsen 2008-12-01 15:06:50 EST
Created attachment 325288 [details]
pm-suspend log file
Comment 2 Lev Shamardin 2008-12-03 01:39:21 EST
Can you please check if you have stuff like this in /var/log/messages after a failed resume?

Dec  2 12:25:35 lopeptoid kernel: Suspending console(s) (use no_console_suspend
to debug)
Dec  2 12:25:35 lopeptoid kernel: [drm:drm_bo_evict_mm] *ERROR* lru empty
Dec  2 12:25:35 lopeptoid kernel: [drm] Num pipes: 1
...
Dec  2 12:25:35 lopeptoid kernel: pci 0000:01:00.0: PCI INT A -> GSI 16 (level,
low) -> IRQ 16
Dec  2 12:25:35 lopeptoid kernel: [drm:radeon_resume] *ERROR* 
Dec  2 12:25:35 lopeptoid kernel: [drm] Loading R500 Microcode
Dec  2 12:25:35 lopeptoid kernel: [drm] Num pipes: 1
Dec  2 12:25:35 lopeptoid kernel: [drm] writeback test failed
Dec  2 12:25:35 lopeptoid kernel: [drm:drm_ttm_bind] *ERROR* Couldn't bind
backend.
Dec  2 12:25:35 lopeptoid kernel: executing set pll
Dec  2 12:25:35 lopeptoid kernel: executing set crtc timing
Dec  2 12:25:35 lopeptoid kernel: [drm] LVDS-8: set mode 1280x800 10
Dec  2 12:25:35 lopeptoid kernel: executing set LVDS encoder
Dec  2 12:25:35 lopeptoid kernel: Restarting tasks ... done.
Comment 3 Mikkel Lauritsen 2008-12-03 14:43:21 EST
Yup:

Dec  3 20:19:23 localhost kernel: [drm:drm_bo_evict_mm] *ERROR* lru empty
...
Dec  3 20:19:23 localhost kernel: [drm] Loading R500 Microcode
Dec  3 20:19:23 localhost kernel: [drm] Num pipes: 1
Dec  3 20:19:23 localhost kernel: [drm] writeback test failed
Dec  3 20:19:23 localhost kernel: [drm:drm_ttm_bind] *ERROR* Couldn't bind backend.

In addition there are shedloads of

Dec  3 20:19:29 localhost kernel: [drm:drm_ttm_bind] *ERROR* Couldn't bind backend.
Dec  3 20:19:29 localhost kernel: [drm:drm_buffer_object_validate] *ERROR* Failed moving buffer. ed69cc00 2048 2000227 10000a0

Is this related to bug 473542?

My smolt profile: http://smolt.fedoraproject.org/show?uuid=pub_e61c3694-eaac-4443-a379-ff089ec9f3b6
Comment 4 Lev Shamardin 2008-12-04 02:35:17 EST
No, bug 473542 is about Intel video cards, and you have ATI. I've found already 5 separate bug reports of this issue with ATI cards and combining it into the most complete bug report and discussion in bug 473195. There is a temporary workaround also: adding nomodeset to kernel arguments helps to solve suspend problem.

*** This bug has been marked as a duplicate of bug 473195 ***

Note You need to log in before you can comment on or make changes to this bug.