Bug 474042 - File Watcher widget crashes Plasma
File Watcher widget crashes Plasma
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 15:31 EST by Jeff Bastian
Modified: 2008-12-22 03:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 18:02:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of plasma crash (6.70 KB, text/plain)
2008-12-01 15:31 EST, Jeff Bastian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 171865 None None None Never

  None (edit)
Description Jeff Bastian 2008-12-01 15:31:16 EST
Created attachment 325291 [details]
backtrace of plasma crash

Description of problem:
The File Watcher widget causes Plasma to crash.  After adding the widget to the desktop and configuring it to watch a file, just clicking on it crashes Plasma.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.3-6.fc10.i386
kdeplasma-addons-4.1.3-1.fc10.i386


How reproducible:
Every time

Steps to Reproduce:
1. Add the File Watcher widget to the desktop
2. Configure it to watch a file, e.g., /var/log/messages
3. Click on it to focus or drag the widget
  
Actual results:
Crash!

Expected results:
No crash

Additional info:
Backtrace of plasma crash is attached.

Looks like upstream bug https://bugs.kde.org/show_bug.cgi?id=168278
Comment 1 Jeff Bastian 2008-12-01 15:34:23 EST
This also sounds similar: https://bugs.kde.org/show_bug.cgi?id=171865

The problem apparently lies in Qt
Comment 2 Rex Dieter 2008-12-21 18:02:19 EST
Hrm, wonder when the "fixed qt upstream" version is forthcoming, no mention in the upstream report.  4.5?  

Either way, we'll do likewise, closed->upstream.
Comment 3 Kevin Kofler 2008-12-22 03:03:19 EST
Have you checked the qt-copy patches?

Note You need to log in before you can comment on or make changes to this bug.