Bug 474043 - Updates are not applied during replica creation
Updates are not applied during replica creation
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Simo Sorce
Chandrasekar Kannan
:
Depends On:
Blocks: 453489
  Show dependency treegraph
 
Reported: 2008-12-01 15:34 EST by Rob Crittenden
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix bug (924 bytes, patch)
2008-12-01 15:38 EST, Simo Sorce
no flags Details | Diff

  None (edit)
Description Rob Crittenden 2008-12-01 15:34:16 EST
Description of problem:

The LDAP updates are not being applied when a replica is created. This is ok for some of them because they be replicated over during the replica creation but anything outside of the base will not be applied, such as plugin configurations.

A call to ds.apply_updates() should be done once the initial replication is done.
Comment 1 Simo Sorce 2008-12-01 15:37:13 EST
Working on it
Comment 2 Simo Sorce 2008-12-01 15:38:29 EST
Created attachment 325292 [details]
patch to fix bug

Added ds.apply_updates() right before restarting services.
Comment 3 Jenny Galipeau 2008-12-03 14:42:04 EST
Can someone give an example of what updates would be missing on the replica if ds.apply_updates was not executed before restarting services?
Thanks
Comment 4 Rob Crittenden 2008-12-03 15:27:50 EST
Look for an index for the attribute ntUniqueId. The dn is:

cn=ntUniqueId,cn=index,cn=userRoot,cn=ldbm database,cn=plugins,cn=config
Comment 5 Jenny Galipeau 2008-12-03 15:33:35 EST
thanks again Rob!
Comment 6 Jenny Galipeau 2008-12-03 15:36:04 EST
Fix Verified:

Search after successful replica installation:

[root@jennyv4 yum.repos.d]# ldapsearch -x -h `hostname` -p 389 -D "cn=Directory Manager" -w Secret123 -b "cn=ntUniqueId,cn=index,cn=userRoot,cn=ldbm database,cn=plugins,cn=config"
# extended LDIF
#
# LDAPv3
# base <cn=ntUniqueId,cn=index,cn=userRoot,cn=ldbm database,cn=plugins,cn=config> with scope subtree
# filter: (objectclass=*)
# requesting: ALL
#

# ntUniqueId, index, userRoot, ldbm database, plugins, config
dn: cn=ntUniqueId, cn=index, cn=userRoot, cn=ldbm database, cn=plugins, cn=con
 fig
objectClass: top
objectClass: nsIndex
cn: ntUniqueId
nsSystemIndex: false
nsIndexType: eq
nsIndexType: pres

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1

Note You need to log in before you can comment on or make changes to this bug.